Support » Fixing WordPress » Reg Level Plugin : Not Working with 2.7

  • mfshearer72


    Get this error:

    Warning: Cannot modify header information – headers already sent by (output started at /home/.chad/mshearer/ in /home/.chad/mshearer/ on line 850

    I disable the Reg Level Plugin and this error disappears. I tried Reg Level on a different site and got a similar error (different location in the code, however).

    I tried going into the plugin to look for whitespaces, as well as the place in the code highlighted by the warning, but no luck.

    Any thoughts?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Sorry for taking so long to get on this. The original code used the wp_redirect() function to send people to the appropriate registration page. Unfortunately, this breaks on many themes and on WP 2.7 in particular.

    I am still planning a fully-featured new release sometime soon (including upgraded features, admin menus, and a built-in user permissions manager), but since I can’t set a specific date I’ve created a temporary “fix” for the plugin. In situations where headers have already been sent (the error above), the plugin instead feeds a meta redirect to the page. This isn’t the best way to do things … but it will work for now and will give me time to finish polishing off version 1.0 of the plugin.

    Enjoy, and let me know if you run into any more problems!

    mfshearer72 – The newest version of the plug-in is now available from the WordPress repository. It no longer uses the wp_redirect() function or the hacked together meta refresh I had set up for the temporary fix. The new version (1.0) uses a completely different – and safe – method for redirection and setting user roles.

    I’ve just installed the upgrade to use with WP 2.71. I get a blank screen when I visit the link

    Am not sure whether it’s the fault of the template but I doubt this since the registration page comes up on my local test

    Scrap that previous post. Plugin works perfectly. It just doesn’t know that I’m using a static homepage in the root directory. It probably needs a little bit of code to figure that out.

    Thanks ericmann for reading my mind so well in advance and making what is now for me a necessary plugin.

    @starapple Any time! 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Reg Level Plugin : Not Working with 2.7’ is closed to new replies.