Support » Plugin: Stripe For WooCommerce » Refund problem

  • Resolved ahumadomayte

    (@ahumadomayte)


    Hi, we have noted that when we make a refund through “stripe credit cards”, an alert displays in our woocommerce saying: “Remote ID of superior order not found.” https://ibb.co/Bw5XqF9

    However, the refund is made correctly if i look into stripe panel. But after clicking Accept on that alert, the refund is not reflected in my woocommerce admin order page, and there are 2 order notes that says:

    First: “Order refunded by Stripe. Amount: € x.xx”
    Second: “Could not refund order in Checkout: Remote ID of superior order not found.”
    https://ibb.co/F0BBQ6L
    https://ibb.co/YpJbWnW

    Is this error related to some misconfiguration both on my stripe panel or in ur plugin? It seems my stripe panel and my woocommerce are not comunicating well when making a refund.

    Respecting webhooks events, i associated the four you mention in ur documentation: https://ibb.co/VMDr7j8
    But i show there are some events i did not select for refund: https://ibb.co/fxMjXQ6. Should i select some of these events for refunds to work?

    Thx.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author mr.clayton

    (@mrclayton)

    Hi @ahumadomayte,

    Webhooks would not be an issue here. I have not come across that error before. Do you have multiple websites that use the same Stripe account?

    The error message references a Checkout ID. That’s not a concept used in this plugin.

    I may have to contact Stripe support to get more information on that error.

    Kind Regards,

    Thread Starter ahumadomayte

    (@ahumadomayte)

    Hi. Yes, we have 3 sites or websites managed under the same stripe account.

    To provide you more information: we have been using WooCommerce stripe plugin (automatic developers, the official one), for four years, and then, 2 days ago we switched to this other plugin.

    With the other one, refunds were made correctly, but other things were a nightmare. With yours all seems to work well, except for the refunds.

    Will you, or can you, consider taking a look on this problem to resolve this issue? We would be very glad if this is resolved.

    Thx

    Plugin Author mr.clayton

    (@mrclayton)

    Hi @ahumadomayte,

    Can you confirm if the refunds in which the Checkout ID issue was observed were orders that were processed using your old Stripe plugin?

    Have you processed any refunds where the payment was made using this plugin? I suspect the issue may be related to the fact that the orders you are refunding were created using your old Stripe plugin.

    Kind Regards,

    Thread Starter ahumadomayte

    (@ahumadomayte)

    Hi. I thouhgt that also, so I made a live payment in our own site with you plugin activated (my customer was not even created in stripe), then proceeded to refund, but same error…

    I uninstalled the other plugin first before trying.

    • This reply was modified 7 months, 3 weeks ago by ahumadomayte.
    Plugin Author mr.clayton

    (@mrclayton)

    @ahumadomayte,

    Are you using Stripe Checkout on any of your other sites that you mentioned?

    Also please provide your account ID (you can do that via the Help button located on the Stripe plugin settings pages). I am going to contact Stripe and see if they can provide any details.

    This issue hasn’t been reported by anyone else and I have never seen it before so I suspect it’s something about your account.

    Kind Regards,

    Thread Starter ahumadomayte

    (@ahumadomayte)

    Hi.

    No, we were using WooCommerce stripe plugin by automatic. Now in our site international cosmetic, we have switched to urs.

    My account id is: acct_1AMIZVAatP6apryH

    I really appreciate your help with this. Thx

    Plugin Author mr.clayton

    (@mrclayton)

    Hi @ahumadomayte,

    Here is an interesting support thread talking about the same issue with another Stripe plugin. It appears to be linked to the Facebook for WooCommerce plugin.

    https://wordpress.org/support/topic/refunds-error-2/

    Do you have that Facebook plugin installed?

    Kind Regards,

    Thread Starter ahumadomayte

    (@ahumadomayte)

    Oh my god… Yes i have that plugin installed, and if i deactivate it, all works well. I never imagine it could be some plugin conflict because of the kind of error, but it is…

    Thx for ur interest. Nice support.

    Plugin Author mr.clayton

    (@mrclayton)

    Hi @ahumadomayte,

    Yes quite strange that the Facebook plugin would cause that conflict. Thanks for confirming.

    If you have a moment I always appreciate a good review.

    https://wordpress.org/support/plugin/woo-stripe-payment/reviews/

    Kind Regards,

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Refund problem’ is closed to new replies.