Support » Plugin: Authorize.Net Payment Gateway WooCommerce Addon » Refund not working properly

  • Hi, I tried to do a partial refund this morning through the WP admin area order edit screen, but when I logged into the gateway to verify, I noticed that the entire order amount was voided. So I had to ask the customer to place his order again, which he thankfully did. Are you aware of this?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author nazrulhassanmca

    (@nazrulhassanmca)

    Do you mean to say this happened in the live mode ?

    Plugin Author nazrulhassanmca

    (@nazrulhassanmca)

    This issue seems to pointed by someone earlier but taking a look at code nothing seems to be wrong in fact and it works fine in sandbox i’ll try again

    Yes, in live mode. I’m having a sale on my website, and I accidentally set the coupon to expire a day too early. So some orders came in without the discount. So on one that was via credit card, I tried to do a partial refund for the customer for the discount amount. But when I checked it in Authorize.net terminal, it showed the transaction as 100% voided.

    Plugin Author nazrulhassanmca

    (@nazrulhassanmca)

    Quick question did the settlement took place before you placed a refund ?

    No, my transactions are “authorize only” So it was only set to authorize the amount, not capture it.

    Plugin Author nazrulhassanmca

    (@nazrulhassanmca)

    That absolute spon on now i would check how refund behaved in authorized only and update you.

    Great, thanks! I don’t do refunds too often, so it’s not critical to me.
    Have you had a chance to look at that POS plugin I sent?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Refund not working properly’ is closed to new replies.