Support » Plugin: APIExperts Square for WooCommerce » Refund Error

  • Resolved colleenkeith

    (@colleenkeith)


    I get this error when trying to process a refund through Woocommerce: An error occurred while attempting to create the refund using the payment gateway API.

    Any ideas? The other people who have brought this up didn’t post answers, as you seemed to support them privately through tickets.

    Thank you for your help.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author WPExperts.io

    (@wpexpertsio)

    Hi @colleenkeith,
    Please make sure that the order status is changed to processing before applying for a refund.

    Thread Starter colleenkeith

    (@colleenkeith)

    Hi there,

    The order status already was “Processing” when applying for the refund. Do you have any other possible solutions?

    Plugin Support wpexpertssupportteam

    (@wpexpertssupportteam)

    Hi @colleenkeith,
    We are unable to replicate this issue at our staging environment can you please share a screencast video so we can look into it.

    Am getting the exact same error

    Can send you logs and screenshot if you send me an email address

    Thanks

    Plugin Support wpexpertssupportteam

    (@wpexpertssupportteam)

    Hi @siteshack @colleenkeith ,
    Unfortunately, we are not allowed to share the email address please open a support ticket at our website so we can help you regarding your issue.

    Thanks!

    Thread Starter colleenkeith

    (@colleenkeith)

    Hi there, I couldn’t make a ticket on your site as I haven’t made a purchase so I sent my video of the issue through your regular contact form. I look forward to hearing from you, thank you!

    Same issue I was having last week. (not solved yet, switched to different square plugin)

    As you are making this very difficult to support this matter perhaps Luke can share the different plugin he used so we can all try that out

    I switched too the lower rated Square for Woocommerce (official) plugin – I don’t recommend that plugin either, but we had to process a few refunds, and we had to do it in a pinch. I don’t have the time to wait for a patch to process a refund as they need to be timely for my clients.

    Plugin Support wpexpertssupportteam

    (@wpexpertssupportteam)

    Hi @luclearmedia @siteshack @colleenkeith,

    We are unable to replicate this issue at our staging environment please have a look at the videos shared below as the refunds are processing without any issues please follow the videos to refund without any issues.

    Refund via Square.

    Refund Manually.

    Thanks!

    Hm, maybe if we can all share our list of plugins we can find a common culprit that may be interfering with the refund – here is my list:

    Advanced Dynamic Pricing for WooCommerce
    All In One WP Security
    Elementor
    Elementor Extras
    Elementor Pro
    Instagram Feed Gallery
    Post SMTP
    PW Woocommerce Gift Cards
    Rank Math SEO
    ShortPixel
    User Registration by WP Everest
    Woocommerce
    Woocommerce Advanced Shipping
    Woocommerce Coupon Generator
    WooCOmmerce PDF Invoices & Packing Slips
    WooSquare

    I know.. lots of plugins but it isn’t a simple site.

    Thread Starter colleenkeith

    (@colleenkeith)

    My client and I have decided to move to Stripe. Our checkout broke for 5 customers over the last few days and this is the 3rd plugin we’ve tried. Square doesn’t work with Woocommerce consistently and all plugins we tried have recent complaints about checkout breaking, and now this one has a refund issue. So we’re moving to Stripe, as it’s endorsed by Woocommerce and they made their own plugin to integrate it. Bye, Square.

    Thanks for the Videos I’ll try it out. However your refund method is by value and not the conventional way of refunding the product. Are you saying that the conventional method will not work?

    Thanks

    Also that method of refunding is not available in the version of WordPress I’m using ( Latest) It is greyed out – you can only refund by applying the refund to the product quantity

    Plugin Support wpexpertssupportteam

    (@wpexpertssupportteam)

    Hi @luclearmedia @siteshack ,
    We have tested it with the latest version of wordpress and woocommerce and the refunds are working properly our technical team needs some more info from your side to resolve this issue please open a support ticker at our website ApiExperts.io

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Refund Error’ is closed to new replies.