Support » Plugin: Wordfence Security - Firewall & Malware Scan » Referrer block not working

  • Resolved smashballoon

    (@smashballoon)


    Hi guys,

    We’re having an issue trying to block some specific requests from websites. The requests are coming from bots from a few specific websites and we want to block the referrers of these requests. Here’s an example of a request we’re trying to block. We’ve tried adding the referrer URL to the blocking settings in multiple different formats (screenshot) but it isn’t blocking the requests.

    Any ideas why this might not be working?

    Many thanks for your help, it’s really appreciated.

    John

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support wfdave

    (@wfdave)

    Hi @smashballoon,

    Can you try adding the pattern *strategicaircraft.com*, for examaple:

    https://i.imgur.com/QQtbgth.png

    Dave

    Hi @wfdave,

    Thanks for the reply! I added that pattern, however, it’s still not successfully blocking requests. Here’s the block rule added at 11:29 and this screenshot shows the requests still coming in at 11:34. Blocking by IP is working correctly but not blocking by referrer.

    Our server is running nginx. Is the referrer blocking compatible with nginx?

    Many thanks,

    John

    • This reply was modified 1 year, 3 months ago by smashballoon.
    Plugin Support wfdave

    (@wfdave)

    I just realized that WordPress/3.4.2; http://strategicaircraft.com is the user-agent.

    Here is an example of another request: https://i.imgur.com/dZYIseY.png – You can see that the first line is the parsed version of the user-agent, and the second line is the raw user-agent.

    The user-agent WordPress/3.4.2; http://strategicaircraft.com isn’t a common user-agent, so it’s listed as undefined in the first row.

    Can you try blocking the user-agent? Use *strategicaircraft.com* on the user-agent field, for example: https://i.imgur.com/3RUv5EI.png

    @wfdave, you’re the man. That worked like a charm, thanks so much for the awesome support! 5-stars!

    Thanks again,

    John

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Referrer block not working’ is closed to new replies.