Support » Plugin: AMP » Referenced AMP URL is not an AMP

  • Resolved Hal

    (@halburgissnet)


    AMP is not working on this installation. All pages are invalid in google search console (new installation, that has been active for about 2+ weeks). If I hover over the Amp reference in the wp-admin bar for one of these pages, it will say “Revalidate (27 errors)”. Clicking on that shows a completely empty list, with this WP error: “Failed to fetch URL(s) to validate. This may be due to a request timeout”. The page loads really quickly so I am not sure that is accurate. There are no console errors and no server log errors. The ampproject validator says: “The mandatory attribute ‘⚡’ is missing in tag ‘html’.” Configuration looks sane, based on other working installations I’ve done. The only thing a little unusual on this installation is that WP is installed in a subfolder. Thx.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Pascal Birchler

    (@swissspidy)

    Hi there,

    https://www.kaocollins.com/inktank/inkjet-creativity-driving-digital-wallpaper-growth/?amp is supposed to be an AMP page, but some plugin seems to cause an issue and not delivering the AMP version at all.

    Could you perhaps share a list of plugins you are using on your site, ideally via the Site Health tool in WordPress admin?

    For debugging, please try temporarily disabling all other plugins and then running the AMP validator again on https://www.kaocollins.com/inktank/inkjet-creativity-driving-digital-wallpaper-growth/?amp

    Hal

    (@halburgissnet)

    Plugins:

    adminimize
    advanced-custom-fields-pro
    amp
    classic-editor
    wordpress-seo
    wp-security-audit-log
    wp-super-cache

    Deactivating did not change anything (I cleared the supercache too just in case).

    Plugin Support James Osborne

    (@jamesosborne)

    @halburgissnet I think there could be issues with plugin compatibility with your site, in particular with caching plugins or hosting features/settings in use. I am encountering issues opening URLs not specific to amp.

    Check or reset your .htaccess file along with temporarily changing your theme and deactivating plugins temporarily before checking again.

    Hal

    (@halburgissnet)

    This is an important production site. I will have to copy it and test with that. Need to find time for that. Thanks.

    Hal

    (@halburgissnet)

    I’m back after taking a break on this. When last I dug into this, and trying to understand the error origins better, I poked around the code. I didn’t get a clear answer there, but seemed like the internal request was failing for some reason, maybe at the server level. So I undid something, which made a difference. All our systems have the server’s hosts file pointing to the internal, loopback ip address for all domains on that server. This is to minimize stuff going out to the network when it doesn’t have to. Removing this, fixed things right up. No more errors and validates fine now. As a footnote, we have other 100% working systems that we didn’t need to take this step. My theory is this one having wp in a subfolder, somehow was part of the problem. Thx.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.