Support » Fixing WordPress » RESOLVED: Can't save menu

  • Resolved Sheila


    I don’t see any way to remove this post but I got my host to reboot the server and the php change did indeed fix this so I’m good to go.


    I’ve combed the Codex and read the tickets and I know this is already a known bug. But it appears some have had success with fixing it. My menu only has about 25 items give or take. Some have issues at 15 and some not until 75.

    There are several threads on the Codex about this known bug and it’s even being worked on in the bug section. But it’s been known for more than a year.

    One of the suggestions when reading the codex was to reset the plugin path. Never done that before. Basically it had me rename the plugin directory and make a blank plugin folder, then login, see NO plug-ins, then go back and delete the empty directory and rename the original one back. It didn’t help.

    I tried this offered solution to no avail:
    Had host change these values in php: = 5000
    suhosin.request.max_vars = 5000

    No joy.

    I had hoped for a workaround I read on one of the threads to make a new menu. So I just tried to recreate the entire menu as a new menu. When I saved it the page stayed blank and when I went back to the menu it looked like I had an new but empty menu. However, I was mistaken. It did save the new menu. I just replaced the old one with the new one. Even though the new one shows all of what I want in the Dashboard Menu when placed and viewed in the site it has not retained all of the items so this is apparently not a viable work-around after all.

    I’m at my wits end. Is anyone aware of a fix? Is this still being worked on? I could use some help. Thanks.

Viewing 1 replies (of 1 total)
  • Moderator Kathryn


    Automattic Happiness Engineer

    In future you can mark a post resolved by using the little drop-down in the right-hand column. I’ll do that for you now.

Viewing 1 replies (of 1 total)
  • The topic ‘RESOLVED: Can't save menu’ is closed to new replies.