• Resolved miko7

    (@miko7)


    Hi,

    I’m having the Reduced by 0 (0 saved) error when using the Optimize button in Library and also bulk optimization. All my files show this.

    Also, I have enabled the log function but not able to find the error log entry for Resmushit at my logs.

    Thank you for your help!

    Regards

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author reSmush.it

    (@resmushit)

    Hi @miko7,

    Thanks for using our plugin 🙂
    If you enable log in your plugin administration page, it should create a resmushit.log at the root of your website. Feel free to send it in this thread.

    This error may be due to a firewall restriction or maybe a Proxy. Do you have such rules ?

    Cheers,
    Charles

    Hi, same problem here, not log is created.

    Yes, I clicked the log option).
    Yes, I deactivate the security plugin.

    We have the same issues Reduced by 0 (0 saved). Tried two sites. Same results

    Plugin Author reSmush.it

    (@resmushit)

    Hi guys,

    Do you have any PHP error log or information to provide us ?

    Cheers,
    Charles

    Isu

    (@isuke01)

    Same error,
    I turned on all debugging – scripts and logs, and php.
    No errors.
    WP:5.3.2
    PHP: 7.3.11 (Supports 64bit values)

    Ajax response:

    total_original_size: 0
    total_optimized_size: 0
    total_saved_size: 0
    total_original_size_nice: 0
    total_optimized_size_nice: 0
    total_saved_size_nice: 0
    percent_reduction: 0
    files_optimized: 0
    files_optimized_with_thumbnails: 0

    Also another bug is –
    if you go to Resmush.it settings. And try save any settings, nothing is happening. Just simply no actions, like button is doing nothing. I tried to disable all other plugins, same effect. Theme is also just blank so it cant interact with it.

    Also other stuff , I’ll open new ticket

    Plugin Author reSmush.it

    (@resmushit)

    Hi guys,

    We’re working on the .log fix which should be available soon, it may bring some new elements to fix the “Reduce by 0” bug.
    We didn’t manage to reproduce it on our development environments, but we’re on it 🙂

    Cheers,
    Charles

    Plugin Author reSmush.it

    (@resmushit)

    Hi @isuke01 @jfarkas @soylaostia @miko7,

    We finally manage to find out what the “Reduce by 0” issue was. It was due to a particular use of the plugin :
    – the “Optimize on upload” option is disabled
    – you optimize manually an attachment

    Now it’s fixed, and a new release (0.3.1) has been released.
    Moreover, a fix has been pushed for log issues (file permissions check were KO)

    We hope everything will be fine for you right now, do not hesitate to send us your feedback 🙂

    If you have the time to send us a review, it would be very kind 🙂

    Cheers,
    Charles

    @resmushit

    I’m running version 0.3.2. Today this Error is displayed to me

    valeriavega

    (@valeriavega)

    Version 0.3.2
    it seems the plugin is able to communicate with your service and even convert the images, but it never saves the result, there are no errors in the log,
    here is one for clicking on optimize, and then force optimize

    [30-04-2020 11:15:27] Revert original image for : /wp-content/uploads/2020/04/Prague-2019-107-scaled.jpg
    [30-04-2020 11:15:29] Optimized file /wp-content/uploads/2020/04/Prague-2019-107-scaled.jpg from 372 KB to 249 KB
    [30-04-2020 11:15:29] Optimized file /wp-content/uploads/2020/04/Prague-2019-107-scaled-240x300.jpg from 37 KB to 33 KB
    [30-04-2020 11:15:29] Optimized file /wp-content/uploads/2020/04/Prague-2019-107-scaled-864x1080.jpg from 112 KB to 84 KB
    [30-04-2020 11:15:30] Optimized file /wp-content/uploads/2020/04/Prague-2019-107-scaled-150x150.jpg from 30 KB to 29 KB
    [30-04-2020 11:15:30] Optimized file /wp-content/uploads/2020/04/Prague-2019-107-scaled-1229x1536.jpg from 177 KB to 125 KB
    [30-04-2020 11:15:31] Optimized file /wp-content/uploads/2020/04/Prague-2019-107-scaled-1638x2048.jpg from 263 KB to 180 KB
    [30-04-2020 11:15:31] Optimized file /wp-content/uploads/2020/04/Prague-2019-107-scaled-600x600.jpg from 65 KB to 52 KB
    [30-04-2020 11:15:31] Optimized file /wp-content/uploads/2020/04/Prague-2019-107-scaled-600x400.jpg from 52 KB to 43 KB
    [30-04-2020 11:15:31] Optimized file /wp-content/uploads/2020/04/Prague-2019-107-scaled-432x540.jpg from 55 KB to 46 KB
    [30-04-2020 11:15:32] Optimized file /wp-content/uploads/2020/04/Prague-2019-107-scaled-540x540.jpg from 59 KB to 48 KB
    [30-04-2020 11:17:18] Revert original image for : /wp-content/uploads/2020/04/Prague-2019-107-scaled.jpg
    [30-04-2020 11:17:20] Optimized file /wp-content/uploads/2020/04/Prague-2019-107-scaled.jpg from 372 KB to 249 KB
    [30-04-2020 11:17:20] Optimized file /wp-content/uploads/2020/04/Prague-2019-107-scaled-240x300.jpg from 37 KB to 33 KB
    [30-04-2020 11:17:20] Optimized file /wp-content/uploads/2020/04/Prague-2019-107-scaled-864x1080.jpg from 112 KB to 84 KB
    [30-04-2020 11:17:21] Optimized file /wp-content/uploads/2020/04/Prague-2019-107-scaled-150x150.jpg from 30 KB to 29 KB
    [30-04-2020 11:17:21] Optimized file /wp-content/uploads/2020/04/Prague-2019-107-scaled-1229x1536.jpg from 177 KB to 125 KB
    [30-04-2020 11:17:21] Optimized file /wp-content/uploads/2020/04/Prague-2019-107-scaled-1638x2048.jpg from 263 KB to 180 KB
    [30-04-2020 11:17:22] Optimized file /wp-content/uploads/2020/04/Prague-2019-107-scaled-600x600.jpg from 65 KB to 52 KB
    [30-04-2020 11:17:22] Optimized file /wp-content/uploads/2020/04/Prague-2019-107-scaled-600x400.jpg from 52 KB to 43 KB
    [30-04-2020 11:17:22] Optimized file /wp-content/uploads/2020/04/Prague-2019-107-scaled-432x540.jpg from 55 KB to 46 KB
    [30-04-2020 11:17:22] Optimized file /wp-content/uploads/2020/04/Prague-2019-107-scaled-540x540.jpg from 59 KB to 48 KB

    all I see in the backend is Reduced by 0 (0 saved)

    reenabled optimize on upload, reactivated plugin, reuploaded a file
    this file was optimized reduced by 331 KB (26.98 % saved)
    after this manual optimization seems to work
    so maybe its related to the first run of automatic optimization.

    went to options
    disabled statistics
    saved the options

    manual optimization broken again
    Reduced by 0 (0 saved)
    reennabling plugin doesn’t help

    uploaded a picture wiht auto optimization
    Reduced by 0 (0 saved)
    reenabled statistics
    manual optimization works again

    disabled optimize on upload
    manual optimization still works

    disabled statistics
    broken again

    So it seems to be tied to Statistics
    disabled preserve exif
    still not working

    disabled logs, enabled statistics (statistics now the only enabled option)
    Reduced by 57 KB (27.83 % saved)

    Without Statistics it doesn’t work
    Cyrillic characters in filename also don’t work

    Plugin Author reSmush.it

    (@resmushit)

    Hi @valeriavega,

    We’ve released today a new version that fix the “Reduce by 0” issue when stats are disabled. Now everything should be fine.

    Can you also provide a screenshot of issues with cyrillic characters. We’ll try to fix it quickly !

    Thanks for these feedback,
    Feel free to review our plugin : https://wordpress.org/support/plugin/resmushit-image-optimizer/reviews/ 🙂

    Cheers,
    Charles

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.