Support » Plugin: WP Photo Album Plus » Reduce load time homepage

  • Resolved Rudolph Smits

    (@rudolph-smits)


    Dear mister Breedvelt

    The load time of my homepage on http://www.magoster.nl scores very low (<20 on 100). I see a lot of javascripts that get loaded for jquery and wppa, I want to try to reduce that.
    When I put my WPPA-photalbum on a separate page that makes no difference for loading javascripts. All the wppa-javascript remain loaded. Is it possible to avoid that for pages on which no wppa is used?

    Regards
    Rudolph Smits

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Jacob N. Breetvelt

    (@opajaap)

    Tick Table IV-A13: 13 Defer javascript
    Install plugin Autoptimize and activate it. Its default configuration of the free version will do, i.e.:
    On the JS, CSS & HTML Tab on the Autoptimize Settings admin page, tick the boxes near:

    JavaScript Options
    Optimize JavaScript Code? [V]

    CSS Options
    Optimize CSS Code? [V]

    HTML Options
    Optimize HTML Code? [V]

    Rudolph Smits

    (@rudolph-smits)

    Thank you for this quick answer and accurate as always.

    I did what you suggested above and my Google speed rating improved from 14 to 27. That’s nice!

    But now I want more… So I thought to remove the wppa photo-album to a seperate page to see the effect. But after removing “[wppa type=”slide” album=”1″ size=”auto”][/wppa]” (and that ONLY!) the javascript didn’t function any more. Have you any idea what could cause that?

    Regards
    Rudolph Smits

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    If there is no wppa activity on the page, the js files for wppa are no longer loaded because of the autoptimize and defer js combination. To speed up the page. That is what you wanted, i thought???

    Make sure you clear the autoptimize cache * in the admin bar ) when you make changes!

    Rudolph Smits

    (@rudolph-smits)

    It is not WPPA that causes a problem. When I choose to Optimize JavaScript Code too then some javascripts don’t run any more. And indeed, always deleting the cache.
    I don’t know why causes this. Possibly to do with jQuery.

    So you have solved my problem on this post, I will open one on the jQuery-forum.

    Thanks once again.

    Rudolph Smits

    (@rudolph-smits)

    Here it is I guess:

    https://wordpress.org/support/topic/jquery-is-not-defined-if-autoptimize-plugin-aggregate-js-files/

    For the moment there is no solution so I had to disable the optimize Javascript. Very disappointing!

    Optimizing Matters

    (@optimizingmatters)

    For the moment there is no solution so I had to disable the optimize Javascript.

    excluding js/jquery/jquery.js from JS optimization should fix most JS issues. if not, what JS errors are visible on the browser console?

    Rudolph Smits

    (@rudolph-smits)

    Thanks!

    There are no errors, some scripts just don’t run any more.

    I tried to exclude jquery-2.2.4.js ut that made no difference.
    Then I saw a box that stops aggregating js-files but does minify them. Well, that works and for the moment I am content with that. I will try to do this on my other sites. Thanks for moving me in this direction!

    Regards
    Rudolph Smits, Holland

    Optimizing Matters

    (@optimizingmatters)

    You’re welcome Rudolph 🙂

    If ever you want to improve more; I see you’re loading 2 versions of jQuery; the one that ships with WordPress (/wp-includes/js/jquery/jquery.js) and https://ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js. Excluding the 2nd one is not needed or useful as AO does not aggregate/ optimize 3rd party hosted scripts, but excluding the first one _should_ work.

    Groeten uit België,
    frank

    Rudolph Smits

    (@rudolph-smits)

    This thread became off-topic.

    Discussion is continued here:
    https://wordpress.org/support/topic/autoptimize-jquery/#post-11215738

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.