Support » Plugin: Redis Object Cache » Redis taking my site back 6 months

  • Resolved Damien

    (@damienmaurer)


    Hi guys,

    Hopefully you can shed some light on what happened.

    6 months ago, I had Redis on. I disabled it as it wasn’t really needed.
    With more logged in traffic, I now wanted to reconsider it.

    So, I activated the Redis plugin and Enabled it.

    Oh boy, bad idea. Because it doesn’t seem to do a Cache purge when it activates, it had the cache from 6 months ago. But my website had moved on since, so WordPress was crapping itself since the files were much more recent – I had the infamous “No update required” message – impossible to bypass.
    Only way forward was to rename the object-cache.php file. But of course it turns off Redis.

    Then I had to reactivate all the plugins that this stunt had deactivated and all was back to normal.

    Anyways, all that to say that it’d be nice to have:
    – A way to flush the cache when the plugin is Active but Redis is not Enabled yet.
    – An automatic flush when activating the plugin
    – A warning of some sort in the UI that this can happen

    I ended up being quite lucky to find a solution, but I can see people restoring a backup to fix the issue!

    Cheers

Viewing 1 replies (of 1 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    Hi Damien!

    I’m glad you got it sorted. The problem with a “Enable and Flush” is that it nukes the database and some people have important data stored in Redis. Ultimately object caching with Redis is an advanced topic and it’s up to the end user to understand it.

    However if you have specific ideas, feel free to open a Pull Request on GitHub with improvements to the documentation or plugin UI 👍

Viewing 1 replies (of 1 total)
  • The topic ‘Redis taking my site back 6 months’ is closed to new replies.