Support » Plugin: Redis Object Cache » Redis Object Cache: Filesystem: Not writeable fault

  • Resolved pss1152

    (@pss1152)


    Dear Developer,

    I cannot fix the attached error.
    I have tried everything.
    Please help me.

    Best regards,

    Csaba Pócsai

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    That means your /wp-content/ folder is not writeable to the plugin.

    Thread Starter pss1152

    (@pss1152)

    Dear Till,

    I do not understand the problem.
    The wp-content directory is owned by http, its group is user.
    All folders are 755 and all files are 644.
    All plugins work flawlessly and are updated.
    I continue to ask for your help.

    Best regards,

    Csaba Pócsai

    Thread Starter pss1152

    (@pss1152)

    Status: Connected
    Client: Predis (v2.0.3)
    Drop-in: Valid
    Disabled: No
    Ping: PONG
    Errors: []
    PhpRedis: Not loaded
    Relay: Not loaded
    Predis: 2.0.3
    Credis: Not loaded
    PHP Version: 8.0.23
    Plugin Version: 2.2.2
    Redis Version: 7.0.7
    Multisite: No
    Metrics: Enabled
    Metrics recorded: 27
    Filesystem: Object cache file doesn’t exist.
    Global Prefix: "pbbqa_"
    Blog Prefix: "pbbqa_"
    WP_REDIS_HOST: "172.18.0.1"
    WP_REDIS_PORT: 46379
    WP_REDIS_DATABASE: 1
    WP_REDIS_PREFIX: "angiszi.hu"
    Global Groups: [
    "blog-details",
    "blog-id-cache",
    "blog-lookup",
    "global-posts",
    "networks",
    "rss",
    "sites",
    "site-details",
    "site-lookup",
    "site-options",
    "site-transient",
    "users",
    "useremail",
    "userlogins",
    "usermeta",
    "user_meta",
    "userslugs",
    "redis-cache",
    "blog_meta"
    ]
    Ignored Groups: [
    "counts",
    "plugins",
    "themes"
    ]
    Unflushable Groups: []
    Groups Types: {
    "blog-details": "global",
    "blog-id-cache": "global",
    "blog-lookup": "global",
    "global-posts": "global",
    "networks": "global",
    "rss": "global",
    "sites": "global",
    "site-details": "global",
    "site-lookup": "global",
    "site-options": "global",
    "site-transient": "global",
    "users": "global",
    "useremail": "global",
    "userlogins": "global",
    "usermeta": "global",
    "user_meta": "global",
    "userslugs": "global",
    "redis-cache": "global",
    "counts": "ignored",
    "plugins": "ignored",
    "themes": "ignored",
    "blog_meta": "global"
    }
    Drop-ins: [
    "advanced-cache.php v by ",
    "Redis Object Cache Drop-In v2.2.2 by Till Krüss"
    ]

    This is the complete diagnostics.

    Plugin Author Till Krüss

    (@tillkruess)

    Filesystem: Object cache file doesn’t exist.

    If your cache works as expected and you don’t have trouble enabling/disabling the cache then you can ignore the errors.

    It seems your filesystem permissions are fairly strict and that’s why the plugin is complaining.

    Thread Starter pss1152

    (@pss1152)

    Something is not working correctly with your plugin.
    I made a new test environment.
    No other plugins are running here.
    The permissions of wp-content are 777, both for directories and files.
    Now I installed phpredis, it is running.
    The error persists.
    What else should I do?
    I did not like it when something does not work correctly.
    So the pro version makes no sense either.
    I attach the diagnostics.

    Status: Connected
    Client: PhpRedis (v5.3.5RC1)
    Drop-in: Valid
    Disabled: No
    Ping: 1
    Errors: []
    PhpRedis: 5.3.5RC1
    Relay: Not loaded
    Predis: Not loaded
    Credis: Not loaded
    PHP Version: 8.0.23
    Plugin Version: 2.2.2
    Redis Version: 7.0.7
    Multisite: No
    Metrics: Enabled
    Metrics recorded: 222
    Filesystem: Object cache file doesn’t exist.
    Global Prefix: "wp_"
    Blog Prefix: "wp_"
    WP_REDIS_HOST: "172.18.0.1"
    WP_REDIS_PORT: 46379
    WP_REDIS_DATABASE: 9
    WP_REDIS_PREFIX: "sega73.hu"
    Global Groups: [
        "blog-details",
        "blog-id-cache",
        "blog-lookup",
        "global-posts",
        "networks",
        "rss",
        "sites",
        "site-details",
        "site-lookup",
        "site-options",
        "site-transient",
        "users",
        "useremail",
        "userlogins",
        "usermeta",
        "user_meta",
        "userslugs",
        "redis-cache",
        "blog_meta"
    ]
    Ignored Groups: [
        "counts",
        "plugins",
        "themes"
    ]
    Unflushable Groups: []
    Groups Types: {
        "blog-details": "global",
        "blog-id-cache": "global",
        "blog-lookup": "global",
        "global-posts": "global",
        "networks": "global",
        "rss": "global",
        "sites": "global",
        "site-details": "global",
        "site-lookup": "global",
        "site-options": "global",
        "site-transient": "global",
        "users": "global",
        "useremail": "global",
        "userlogins": "global",
        "usermeta": "global",
        "user_meta": "global",
        "userslugs": "global",
        "redis-cache": "global",
        "counts": "ignored",
        "plugins": "ignored",
        "themes": "ignored",
        "blog_meta": "global"
    }
    Drop-ins: [
        "Redis Object Cache Drop-In v2.2.2 by Till Krüss"
    ]
    Plugin Author Till Krüss

    (@tillkruess)

    I dug into this. The issue is that: WP_REDIS_PLUGIN_PATH . '/includes/object-cache.php' doesn’t exist according to your PHP process.

    Thread Starter pss1152

    (@pss1152)

    Okay.
    How can I fix this?

    Plugin Author Till Krüss

    (@tillkruess)

    Are you using a standard WordPress setup, or is it customized?

    Where did you install the redis-cache plugin directory?

    Thread Starter pss1152

    (@pss1152)

    Standard WP setup.

    /sega73.hu/wp-content/plugins/redis-cache

    From /sega73.hu/wp-content/plugins/redis-cache/includes copy object-cache.php to /sega73.hu/wp-content/

    Wp-config.php is define:

    //Redis
    define( ‘WP_REDIS_HOST’, ‘172.18.0.1’ );
    define( ‘WP_REDIS_PORT’, 46379 );
    define( ‘WP_REDIS_DATABASE’, 9 );
    define( ‘WP_REDIS_PREFIX’, ‘sega73.hu’ );
    define( ‘WP_CACHE’, true );

    Plugin Author Till Krüss

    (@tillkruess)

    In that case you’ll have to debug this yourself, or get a developer to do it for you. I doubt it’s a plugin issue, since it’s working for everyone one else. It’s likely your filesystem permissions.

    Thread Starter pss1152

    (@pss1152)

    On the test website I have given 777 permissions, but it doesn’t work there either.
    This must be a plugin problem.

    Plugin Author Till Krüss

    (@tillkruess)

    In that case you’ll have to debug the code yourself, or get a developer to do it for you.

    Thread Starter pss1152

    (@pss1152)

    In this case, it can be said that:

    • the plugin is not working properly
    • it is trying to access something it has nothing to do with
    • could there be a “backdoor” in it?
    Plugin Author Till Krüss

    (@tillkruess)

    OMG. There is no backdoor and it’s not accessing anything outside its own plugin directory.

    The plugin is working fine. See below.

    Status: Connected
    Client: PhpRedis (v5.3.5RC1)
    Drop-in: Valid
    Thread Starter pss1152

    (@pss1152)

    I found a bug in the plugin.
    It does not work correctly when “‘FS_METHOD’, ‘ssh2′” is set.
    You have to change it to “‘FS_METHOD’, ‘direct'”, then it works perfectly.
    This needs to be fixed.

    Status: Connected
    Client: PhpRedis (v5.3.5RC1)
    Drop-in: Valid
    Disabled: No
    Ping: 1
    Errors: []
    PhpRedis: 5.3.5RC1
    Relay: Not loaded
    Predis: Not loaded
    Credis: Not loaded
    PHP Version: 8.0.23
    Plugin Version: 2.2.2
    Redis Version: 7.0.7
    Multisite: No
    Metrics: Enabled
    Metrics recorded: 68
    Filesystem: Working
    Global Prefix: "wp_"
    Blog Prefix: "wp_"
    WP_REDIS_HOST: "172.18.0.1"
    WP_REDIS_PORT: 46379
    WP_REDIS_DATABASE: 9
    WP_REDIS_PREFIX: "sega73.hu"
    Global Groups: [
        "blog-details",
        "blog-id-cache",
        "blog-lookup",
        "global-posts",
        "networks",
        "rss",
        "sites",
        "site-details",
        "site-lookup",
        "site-options",
        "site-transient",
        "users",
        "useremail",
        "userlogins",
        "usermeta",
        "user_meta",
        "userslugs",
        "redis-cache",
        "blog_meta"
    ]
    Ignored Groups: [
        "counts",
        "plugins",
        "themes"
    ]
    Unflushable Groups: []
    Groups Types: {
        "blog-details": "global",
        "blog-id-cache": "global",
        "blog-lookup": "global",
        "global-posts": "global",
        "networks": "global",
        "rss": "global",
        "sites": "global",
        "site-details": "global",
        "site-lookup": "global",
        "site-options": "global",
        "site-transient": "global",
        "users": "global",
        "useremail": "global",
        "userlogins": "global",
        "usermeta": "global",
        "user_meta": "global",
        "userslugs": "global",
        "redis-cache": "global",
        "counts": "ignored",
        "plugins": "ignored",
        "themes": "ignored",
        "blog_meta": "global"
    }
    Drop-ins: [
        "Redis Object Cache Drop-In v2.2.2 by Till Krüss"
    ]
Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.