• Resolved aga2442

    (@aga2442)


    Hello,

    I have started using the redis feature and your plugin over plesk panel (docker) for the last 2 weeks.

    my websites do not have extremely large traffic.

    but I noticed that my websites were down 3 times in the last 2 weeks.

    when I check; the redis feature in the plesk panel (in the docker section) is disabled. when I re-enable it, the problem naturally corrects.

    I am not saying that this problem is related to your plugin.

    but I wanted to share it with you in case it might help.

    this problem last happened last night and the last records in the redis field in the last plesk panel are as follows:

    1075:C 23 Apr 2024 00:07:20.264 * DB saved on disk
    1075:C 23 Apr 2024 00:07:20.270 * Fork CoW for RDB: current 2 MB, peak 2 MB, average 2 MB
    1:M 23 Apr 2024 00:07:20.323 * Background saving terminated with success
    1:M 23 Apr 2024 00:12:21.096 * 100 changes in 300 seconds. Saving…
    1:M 23 Apr 2024 00:12:21.109 * Background saving started by pid 1076
    1076:C 23 Apr 2024 00:12:23.057 * DB saved on disk
    1076:C 23 Apr 2024 00:12:23.065 * Fork CoW for RDB: current 2 MB, peak 2 MB, average 1 MB
    1:M 23 Apr 2024 00:12:23.120 * Background saving terminated with success
    1:M 23 Apr 2024 00:17:24.051 * 100 changes in 300 seconds. Saving…
    1:M 23 Apr 2024 00:17:24.065 * Background saving started by pid 1077
    1077:C 23 Apr 2024 00:17:26.037 * DB saved on disk
    1077:C 23 Apr 2024 00:17:26.045 * Fork CoW for RDB: current 3 MB, peak 3 MB, average 2 MB
    1:M 23 Apr 2024 00:17:26.082 * Background saving terminated with success
    1:signal-handler (1713831534) Received SIGTERM scheduling shutdown…
    1:M 23 Apr 2024 00:18:54.721 * User requested shutdown…
    1:M 23 Apr 2024 00:18:54.721 * Saving the final RDB snapshot before exiting.
    1:M 23 Apr 2024 00:18:56.308 * DB saved on disk
    1:M 23 Apr 2024 00:18:56.308 # Redis is now ready to exit, bye bye…
    1:C 23 Apr 2024 07:28:28.783 # WARNING Memory overcommit must be enabled! Without it, a background save or replication may fail under low memory condition. Being disabled, it can also cause failures without low memory condition, see https://github.com/jemalloc/jemalloc/issues/1328. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
    1:C 23 Apr 2024 07:28:28.783 * oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
    1:C 23 Apr 2024 07:28:28.783 * Redis version=7.2.4, bits=64, commit=00000000, modified=0, pid=1, just started
    1:C 23 Apr 2024 07:28:28.783 # Warning: no config file specified, using the default config. In order to specify a config file use redis-server /path/to/redis.conf
    1:M 23 Apr 2024 07:28:28.783 * monotonic clock: POSIX clock_gettime
    1:M 23 Apr 2024 07:28:28.784 * Running mode=standalone, port=6379.
    1:M 23 Apr 2024 07:28:28.784 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
    1:M 23 Apr 2024 07:28:28.786 * Server initialized
    1:M 23 Apr 2024 07:28:28.786 * Loading RDB produced by version 7.2.4
    1:M 23 Apr 2024 07:28:28.786 * RDB age 25774 seconds
    1:M 23 Apr 2024 07:28:28.786 * RDB memory usage when created 135.62 Mb
    1:M 23 Apr 2024 07:28:30.134 * Done loading RDB, keys loaded: 121185, keys expired: 47.
    1:M 23 Apr 2024 07:28:30.134 * DB loaded from disk: 1.348 seconds
    1:M 23 Apr 2024 07:28:30.134 * Ready to accept connections tcp
Viewing 1 replies (of 1 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    Thanks for reporting this. I’d suggest asking your hosting provider why Redis Server is shutting down on it’s own and doesn’t restart automatically.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.