Support » Plugin: Redis Object Cache » Redis do not connect via plugin even if it connects via terminal

  • Resolved Anonymous User 20930405

    (@anonymized-20930405)


    Hi there,

    I am trying to test out object cache with Redis. I have set up a server from redislabs.com, and I successfully connected to it via terminal on my computer. Having passed all the required information on the wp-config file, I still can’t get connected via WordPress. Here is the diagnostics:

    Status: Not connected
    Client: PhpRedis (v5.3.6)
    Drop-in: Valid
    Disabled: No
    Ping: 
    Connection Exception: Connection refused (RedisException)
    Errors: [
        "Connection refused"
    ]
    PhpRedis: 5.3.6
    Relay: Not loaded
    Predis: Not loaded
    Credis: Not loaded
    PHP Version: 8.1.16
    Plugin Version: 2.2.4
    Redis Version: Unknown
    Multisite: No
    Metrics: Disabled
    Metrics recorded: 0
    Filesystem: Working
    Global Prefix: "lekitable_"
    Blog Prefix: "lekitable_"
    WP_REDIS_SCHEME: "tls"
    WP_REDIS_HOST: "redis-18269.c300.eu-central-1-1.ec2.cloud.redislabs.com"
    WP_REDIS_PORT: REDACTED_FOR_PRIVACY
    WP_REDIS_PREFIX: "lekitable"
    WP_CACHE_KEY_SALT: "lekitable"
    WP_REDIS_PLUGIN_PATH: "/usr/www/users/lekita/wordpress/wp-content/plugins/redis-cache"
    WP_REDIS_PASSWORD: ["default","••••••••"]
    Global Groups: [
        "blog-details",
        "blog-id-cache",
        "blog-lookup",
        "global-posts",
        "networks",
        "rss",
        "sites",
        "site-details",
        "site-lookup",
        "site-options",
        "site-transient",
        "users",
        "useremail",
        "userlogins",
        "usermeta",
        "user_meta",
        "userslugs",
        "redis-cache"
    ]
    Ignored Groups: [
        "counts",
        "plugins",
        "themes",
        "blog-details",
        "blog-id-cache",
        "blog-lookup",
        "global-posts",
        "networks",
        "rss",
        "sites",
        "site-details",
        "site-lookup",
        "site-options",
        "site-transient",
        "users",
        "useremail",
        "userlogins",
        "usermeta",
        "user_meta",
        "userslugs",
        "redis-cache",
        "blog_meta",
        "trp"
    ]
    Unflushable Groups: []
    Groups Types: {
        "blog-details": "ignored",
        "blog-id-cache": "ignored",
        "blog-lookup": "ignored",
        "global-posts": "ignored",
        "networks": "ignored",
        "rss": "ignored",
        "sites": "ignored",
        "site-details": "ignored",
        "site-lookup": "ignored",
        "site-options": "ignored",
        "site-transient": "ignored",
        "users": "ignored",
        "useremail": "ignored",
        "userlogins": "ignored",
        "usermeta": "ignored",
        "user_meta": "ignored",
        "userslugs": "ignored",
        "redis-cache": "ignored",
        "counts": "ignored",
        "plugins": "ignored",
        "themes": "ignored",
        "blog_meta": "ignored",
        "trp": "ignored"
    }
    Drop-ins: [
        "advanced-cache.php v by ",
        "maintenance.php v by ",
        "Redis Object Cache Drop-In v2.2.4 by Till Krüss"
    ]

    As well as bellow you can find the part of my wp-config file:

    define( 'WP_CACHE_KEY_SALT', 'lekitable' ); 
    define( 'WP_REDIS_SCHEME', 'tls' );
    define( 'WP_REDIS_HOST', 'redis-18269.c300.eu-central-1-1.ec2.cloud.redislabs.com' );
    define( 'WP_REDIS_PORT', REDACTED_FOR_PRIVACY );
    define('WP_REDIS_PASSWORD', ['default','REDACTED_FOR_PRIVACY']);

    Do you have any idea why is this happening ? Please note that all of these details are mentioned on top of the wp-config

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Redis do not connect via plugin even if it connects via terminal’ is closed to new replies.