Support » Plugin: Redis Object Cache » Redis cache memory full, site shows 500

  • Resolved csmicfool

    (@csmicfool)


    We quickly filled up the cache we were testing on a WPMU network.

    When this occurred everything just errors out.

    Is there any way to enable automatic purging on this type of failure? What is recommended?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    You mean your Redis database was full and WordPress tried to add more data?

    Correct

    This is something you should configure in the redis.conf. It is Redis’s job to discard objects when it runs out of allocated RAM, not the plugin’s.

    Add this to redis.conf

    # how redis will evict old objects - least recently used
    maxmemory-policy allkeys-lru
    • This reply was modified 3 years, 10 months ago by blindpet.
    • This reply was modified 3 years, 10 months ago by blindpet.

    Thanks!

    For Azure, it looks like the correct setting is under Advanced Settings > maxmemory-policy. ‘allkeys-lru’ is one of the dropdown options.

    Did that solve your issue @csmicfool? What was it set to previously?

    previously was volatile-lru, I haven’t hit the limit again yet but I’m confident it’s not on the plugin side.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Redis cache memory full, site shows 500’ is closed to new replies.