Support » Plugin: Redis Object Cache » Redis Cache goes to frontpage instead of to admin

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    Try flushing your Redis database.

    Hi Till,
    How do I do that?
    Thanks.

    Plugin Author Till Krüss

    (@tillkruess)

    You can use wp cache flush or redis-cli flushdb when logged in via SSH.

    Hi Till,
    I am sorry, but I have no idea how to do that.
    Can you maybe make a manual, step by step, so that I can do that?
    Thanks.

    Plugin Author Till Krüss

    (@tillkruess)

    That’s outside the scope of support for the free version. I’d suggest asking your hosting provider for assistance.

    Well that isn’t very friendly.
    I don’t understand. Doesn’t a plugin has to work like that? Without all the difficult things?
    For now I will disable it.
    If there is somebody, that can help me, please write me.
    Johanna

    Plugin Author Till Krüss

    (@tillkruess)

    No, this plugin requires you installing and managing a Redis Server. Without it, it won’t work.

    That’s fairly advanced, and if it’s outside your expertise, it’s much better to use W3 Total Cache or WP Rocket to improve your site’s speed.

    Ok. I never knew I had to install and manage a Redis server.
    Why is this among the plugins then?
    Until now it always worked and on my other site it works.

    Plugin Author Till Krüss

    (@tillkruess)

    Ok. I never knew I had to install and manage a Redis server.

    The plugin doesn’t work without Redis Server running on the same machine.

    Why is this among the plugins then?

    So people can install the plugin? 🤷‍♂️

    Until now it always worked and on my other site it works.

    Do you see “Status: Connected” when you go to Settings -> Redis on the sites you believe are working?

    johanna2patricia

    (@johanna2patricia)

    On the other site that is working, I get under Settings->Redis this:

    Redis Object Cache
    OverviewMetricsDiagnostics
    Overview
    Client: Predis (v1.1.4)
    Drop-in: Valid
    Connection
    Status: Connected
    Host: 185.104.28.32
    Port: 8892
    Username: S
    Password: ••••••••
    Database: 0
    Connection Timeout: 1s
    Read Timeout: 1s
    Redis Version: 3.0.2
    Flush Cache Disable Object Cache

    And on the site that isn’t working I get this under Settings –>Redis:

    Error Thrown
    Call to a member function zrangebyscore () on null

    Plugin Author Till Krüss

    (@tillkruess)

    Can you post the full diagnostics for the site where it doesn’t work?

    johanna2patricia

    (@johanna2patricia)

    What diagnostics do you mean?
    When I enable it, I can’t get into admin.
    When the plugin isn’t activated, I get the message above.
    Maybe you can contact me through email?
    Then we can post the solution here afterwards.
    My email is: johanna@libralion.com

    Johanna

    Plugin Author Till Krüss

    (@tillkruess)

    I don’t provide email support. I’d recommend hiring a developer to assist you with you issue.

    johanna2patricia

    (@johanna2patricia)

    I don’t know who to ask.
    And I don’t understand why you don’t want to help me.
    I am pretty good with computers, but not with scripts. For now I will disable the plugin.

    Plugin Author Till Krüss

    (@tillkruess)

    I recommend UpWork for hiring WordPress developer to assist you with this.

Viewing 15 replies - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.