Support » Plugin: Redis Object Cache » Redis cache and acf compatibility

  • Resolved bohr

    (@bohr)


    Hi,
    I noticed a strange behaviour while using acf, redis cache and polylang together.
    I created a set of ACF for my custom post, both in ita and eng language.
    When I go to my custom post type editor page, with the redis cache disabled, I see my set of acf according to the language of the custom post.
    When I activate redis cache, I just see the italian (or the english) fields, no matter what the custom post language is, as if the acf blocks where cached.

    It looks like it’s a known issue, also for WPML:
    https://wpml.org/forums/topic/multiple-acf-field-groups-display-when-group-is-duplicated-to-a-2nd-language/

    the only workaround I know is to temporarily disable redis cache when I am editing my posts, but it’s not a very good option.
    Am i missing something?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    WPML is notoriously bad at caching, amongst other things.

    I’d suggest disabling all the wpml cache groups in your installation. You should still be able to cache ACF without issues.

    bohr

    (@bohr)

    sorry for being unclear: I am using Polylang pro. Is there any workaround other than disabling redis when I am editing posts?

    Plugin Author Till Krüss

    (@tillkruess)

    Yes, you can ignore the Polylang Pro cache groups in your config. That will resolve the issue.

    bohr

    (@bohr)

    thanks! may you point me out an example? Are you referring to wp-config file or what?
    thank you a lot

    Plugin Author Till Krüss

    (@tillkruess)

    You can search this forum for examples on how to ignore groups.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.