Support » Plugin: WPS Hide Login » Redirects to 404 Page

  • Resolved snodak

    (@snodak)


    I’ve been using WPS Hide Login for about 2 years and never had a problem. I believe over the last weekend my login URL stopped working and redirected me to the 404 page. So I disabled WPS Hide Login and everything works (Except I have to use the default login URL). Thanks in advance for any assistance.

Viewing 9 replies - 1 through 9 (of 9 total)
  • I have the same problem just started recently.Getting 404 page.

    I had the same problem and reported, they called me that I don’t how to configure. Incompetent developer blaming others.

    Gave this plugin a try and got the same problem, had to uninstall it.

    Plugin Author NicolasKulka

    (@nicolaskulka)

    permalinks, htaccess or conflict plugin

    I also experience the same issue no changes have been made to permaliks / htaccess or plugin changes it just stopped working properly without any changes being made to the site I’ve since disabled the plugin – was checking here to see if there has been any update as I really like this plugin.

    Thread Starter snodak

    (@snodak)

    @nicolaskulka

    I re-saved my permalinks to “Post Name”. It still redirects to the 404 page.
    I disabled all other plugins. It still redirects to the 404 page.
    I removed everything from the htaccess file that was not default. It still redirects to the 404 page.
    I even deleted the plugin and redownloaded it. It still redirects to the 404 page.

    Hi, I have the same problem, in my case when the issue happend I checked the .htaccess file and the last modified date of the file was changed, editing the file I found that the code for WPS Hide Login dissapear, I mannualy included again this code at the end of .htaccess file and the problem was solved but i do not know why or what changed the .htacess file, I had this problem in two websites and in both I ahve seen the same issue.

    # Hide Login
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    #END Hide Login

    In short, this rewrite rule tells your Apache server if the requested (%REQUESTED_FILENAME) file (-f) or folder (-d) does not exists (!), then “sends the user to our index.php page”.

    A nice hack to cover wrongdoings of people trying to open random pages/folders that do not exist, but this “fix” does not apply to other servers (nginx or IIS) since it is a workaround for Apache only and doesn’t change the fact the code is incorrect.

    • This reply was modified 1 year, 3 months ago by hquest.

    Did clean install and still having a issue – Can uppercase and numbers be used?

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Redirects to 404 Page’ is closed to new replies.