• Resolved orbit0

    (@orbit0)


    After updating from “Redirection for Contact Form 7” v1.3.7 to v2.2.1, rediretion stopped working. The form sent fine, it just didn’t redirect at all. Instead it displayed the default green-boxed Submission results at the very bottom of the form page.

    Tried manually setting the redirection URL in Action settings, and got the same result. Form sent but still would not redirect to the results page we had set up.

    Rolled back to v 1.3.7 of this plugin (glad I made a backup before upgrading!), and redirection works perfectly again.

    Just mentioning this here in case anyone else has the same problem. Rollback to v 1.3.7 solves the problem.

Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Contributor Yuval

    (@yuvalsabar)

    @orbit0,

    Can you send a list of installed plugins on your website so we can test this?

    Version 1.3.7 is always available here:
    https://he.wordpress.org/plugins/wpcf7-redirect/advanced/

    Yuval,
    Query Solutions Ltd.

    Hi @yuvalsabar, I have the same problem that orbit0, and solve rolled back to v1.3.7

    To help the update of the plugin, I give you the plugins installed in my website:

    Theme: Avada
    – Ajax Search Lite
    – Avada Builder
    – Avada Core
    – CF7 Google Sheet Connector
    – Contact Form 7
    – Contact Form 7 Captcha
    – Contact Form 7 Conditional Fields
    – Contact Form CFDB7
    – Drag and Drop Multiple File Upload – Contact Form 7
    – iThemes Security
    – LiteSpeed Cache
    – PDF Embedder
    – Pre* Party Resource Hints
    – Rank Math SEO
    – Redirección a Contact Form 7 Pro
    – UpdraftPlus – Backup/Restore
    – WP Mail SMTP

    Hope, can help to solve the problem. Thanks.

    Thread Starter orbit0

    (@orbit0)

    The only things my websites have in common with Cristian’s website are Contact Form 7 and this plugin. Nothing else is the same.

    Plugin Contributor Yuval

    (@yuvalsabar)

    Hi @orbit0,

    In order to help, we need to know exactly what plugins you have installed in your website. Also, please provide a link to your website.

    Hello,

    After the update of the plugin I also have a problem with REDIRECTION that is not working on the mobile version (on my phone). on the computer is ok.

    I am not a computer expert so can you please help me solve this in a easy way?

    How can I go back to the previous version of the plug in (if this is the solution)?
    (i tried the link you put above but i have no idea where to start / what to do)

    I really appreciate your help if we can solve it quick because there is a payment page involved in this.

    thank you in advance!

    Federica

    • This reply was modified 3 years, 8 months ago by federicama.

    Hi @federicama, with WP Rollback ( https://wordpress.org/plugins/wp-rollback/ ) You can ‘rollback’ any theme and plugin to previous versions.

    I am having the same experience on multiple sites, all running WP 5.5.1. The issue persists with all plugins off (except for CF7 and RfCF7). It persists across theme changes.

    When the redirect fails, it is due to a jQuery error. “$ is not a function” – which comes from the file wpcf7-redirect-frontend-script.js in the build folder. When I search/replace “$” with “jQuery” and re-upload this file, the issue resolves. It appears that noconflict mode is not properly being worked around.

    • This reply was modified 3 years, 8 months ago by jcmmediagroup.

    Please update the plugin to VER 2.2.2 and let us know if the problem presists

    @querysolutions I’ve tried the upgraded version but still not working on mobile

    @crist0sant0 You saved me with the ROLLBACK plugin! thank you 😀

    thank you all

    Hi @federicama,

    What mobile device do you use?

    2.2.3 resolved the issue for me across all devices and browsers. Great resolution speed, thanks a million.

    @federicama, did you try clearing the device cache on your mobile? For example, on an iPhone this is under Settings > Safari > Clear History and Website Data

    My guess is that you have some old jQuery stuck in your device’s cache.

    • This reply was modified 3 years, 8 months ago by jcmmediagroup.

    The redirects stopped working for me too – I get 500 Internal Server Error in the console and logs, but no specific information that indicates why this is happening.

    Which version are you using ?

    @jcmmediagroup @querysolutions
    hello! thank you, I cleared the cache and updated to the last version of the plugin and now it is working!

    thank you all

    All my redirects are gone after upgrading. I didn’t have them written down so now I am trying to re-program.

    Also, when carrying a parameter from a rodio select, it doesn’t work. It’s adding some characters like BD% the URL looks like this;

    domain.com?variableDB%D=test

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Redirects stopped working after update to v2.2.1’ is closed to new replies.