Support » Alpha/Beta/RC » Redirects for Mutisite 3.5-beta3

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hugh

    (@sillinguist)

    Oh, I have tried putting the Rewrite rules between the </IfModule> tags too. same problem…

    I mentioned this on Trac also, but I’ll copy it here for full coverage.

    The htaccess instructions were fixed in r22982.

    Hugh

    (@sillinguist)

    So does this mean I need to delete the currently active rules and then update to the nightly and then re-apply the redirect rules?

    Also: for the maintainers… the screenshot above where the red circle is, that path needs adjusted when the subdomain option is evoked.

    Hugh

    (@sillinguist)

    @even, Oh I think I mis read what you wrote, I see that you are referencing the bad instructions, not my bad Rewrite rules… but I remain locked out of my install.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Hugh, upgrade to trunk first, before we go a-hunting 🙂

    The screenshot link doesn’t work, BTW.

    Hugh

    (@sillinguist)

    @ipstenu,

    Thanks I just did that, or actually I upgraded to 3.5-BetaRC5. Also I re-shared the image above and here it is.

    And I can verify that the instructions were fixed. I also realized (by looking here) that the I was missing

    $base = '/'; from the code set below:

    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    $base = '/';
    define('DOMAIN_CURRENT_SITE', 'example.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    I am pretty sure that just copy and pasted from what was given to me in RC3. In fact if you look at the screen shot from RC3, the missing code is not in there. RC3 is now behind us, so no sorrow there, but I wonder what it says in RC5. I didn’t set up a clean database and I don’t see a quick and easy way to un-install the network tables, which are needed for WP to automagically allow me to set-up a sub.domain based install. (otherwise WP detects a network already present and only offeres me a sub/folder based approach. )

    I added the $base = '/'; and worked my way backwards so now I have multisite working with one exception.

    1. I tried to use the link provided in this image to go from the admin menu to the specified site. When I click the menu link it goes to$base/wordpress/wordpress/wordpress/wordpress where $base is my domain name. (You can see the actual domain name in the images, but I am not using in the forums – that just seems like best practice.) and there seems to be no end to the number of wordpress/ segments in the url before things time out.
    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Going through the steps myself…

    1. Install WP in ipstenu.loc/wp
    2. Change URLs to run from ipstenu.loc
    3. Verify pretty permalinks work right
    4. Multisite me!
    5. http://cl.ly/image/3j1s1W2k0E1T

    So … It works as expected if you flip to root before Multisiting.

    Hugh

    (@sillinguist)

    Thanks. I totally got this now…
    I totally removed the $base = '/'; and went back and deleted the /wordpress from the install location and now all seams to be in order. But from a UX perspective it is a bit counter intuitive to remove the /wordpress from the single wordpress install before upgrading to multisite. Page 13 of your 101 book helped me (I think i missed it the first time because the example is spread across two pages.). thanks again.

    I am not sure why $base = '/'; is included in your book…

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Redirects for Mutisite 3.5-beta3’ is closed to new replies.