WordPress.org

Forums

Redirection problem after upgrading to 2.5 (5 posts)

  1. BiynDesigns
    Member
    Posted 6 years ago #

    I upgraded from 2.3.3 to 2.5, now I can't long in to the administration section. My site main URL is http://www.biyn-web-designer.com/blog...
    the user friendly name that redirects to the above is http://www.biyndesigns.com/blog.

    Here is the error message I get when I try logging in using firefox.
    As soon as I log in the URL reads like this: http://www.biyn-web-designer.com/blog/wp-admin/

    The page isn't redirecting properly

    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

    I've tried using the "disable-cononical-redirects plugging" that didn't work.

    Any help would be appreciated...

  2. silfani
    Member
    Posted 6 years ago #

    I have the same issue, eternal redirect to the site. I managed to access the admin screens.

    This has something to do with the aliasing problem I've been having with this particular installation on this server. My personal server works great, but not this one.

    As I had to modify files using an ugly hack to solve the tilde issue in 2.2 and 2.3, I will try to do the same here.

    Previously I modified wp-includes/functions.php by inserting the following at line 1030 in wordpress 2.2 or 915 in wordpress 2.3 (or at the beginning of function wp_referer_field):

    $_SERVER['REQUEST_URI'] = preg_replace( "/%7[Ee]/", "~", $_SERVER['REQUEST_URI'] );

  3. silfani
    Member
    Posted 6 years ago #

    Actually try this.

    Download this plugin. Install it, activate it.

    http://txfx.net/files/wordpress/disable-canonical-redirects.phps

    My original fix to the pagenum links is no longer working, but at least this fixes the eternal redirect.

  4. BiynDesigns
    Member
    Posted 6 years ago #

    It worked this time around!!!
    I had to downgrade to 2.3.3, then upload disable-canonical-redirects.phps,
    activate it, and then upgrade to 2.5.

    I'm all set. Thanks for your help!!

  5. DouglasVB
    Member
    Posted 6 years ago #

    i get the same problem as the first post. it continues to happen with 2.5.1. is there going to be a real fix for this, rather than just disabling canonical redirects, soon?

Topic Closed

This topic has been closed to new replies.

About this Topic