Support » Plugin: Restrict User Access - Membership Plugin with Force » Redirection issues as from last update

  • Hello ,

    As of the last update I am experiencing bad redirections of all my pages with restricted content and those related to Woocommmerce (from where I sell these restricted content) for example:

    I have deactivated all plugins and I could verify that RUA is causing this issue. 

    Whenever you type an address, (for example, you will be redirected to Store: .  In the nav bar you would read this address followed by a tail corresponding to “brutalismo ” in this case:  However, you will again land in the Store and NOT in “brutalismo” page. 

    I have tried renaming the pages and also setting them to Private and the issue persists: “argentina-del-progreso” content keeps on being displayed when you go to Additionally, you would continue to experience strange issues if you write in your browser, You will be redirected – This issue is replicating in every page containing restricted content sold through Woocommerce`

    If you go to you will again land in this page with restricted content (Argentina del Progreso – Introductorio)

    Content of this page belongs to This page is definitely related to Woocommerce as it is the URL (and download link) of the restricted content for product in . However, If you paste this address in the nav bar you will experience redirection to and this redirection issue is now present in every URL containing the restricted content I am selling through Woocommerce. At this moment all pages related to protected content sold through Woocommerce would  show this redirection issues Examples:, etc.

    All of the products show the same issue. None of the redirections however take you to the corresponding page. They all land in the STORE followed by the redirection slug example: ?redirect_to=%2Ftipologias-de-viviendas%2F

    Argentina-del-progreso, is one of the most problematic pages. It will show up anywhere. It is the page to where you would be wrongly redirected.
    For instance, if you try to make any purchase bearing restricted content, you will experience that checkout process gets broken at “Comprar” button as well as  in the case of clicking “view cart” (Ver Carrito): you will be redirected to this page.
    You should be derived to instead, but you will see argentina-progreso content displayed again, so checkout process is broken

    This issue shows up even in some pages which are not related to RUA or to WOOCOMMERCE, such as

    For your reference, 

    I am using Automator WP-Plugin and Automator Schedule Action in order to set up membership duration. (This plugin allows me to set permissions to each role allowing to view restricted  content  they purchased during a given period of time).

    I am also having issues with Woocommerce where download link shows errors, ( )

    As from the previous RUA update, you instructed me to set Tease & Include urls. Now, all these pages are properly set up. The alert of “Not Set” has dissapeared. 

    Because they are related, I tested deactivating an re-activating both Automator and Woocommerce and the issue persists.

    I can confirm that issue is caused by RUA. I tried disabling and re-activating it several times and every time I deactivate RUA things get fixed, none of thee errors show up, but of course all restricted content gets displayed  this is why I come to the forum, so that you can find the root cause for the issue and help me fix it. 

    Thank you very much


    • This topic was modified 2 months, 2 weeks ago by aflorarte.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter aflorarte


    Hello again,

    I have placed a new ticket now referring to login difficulties. Please refer to

    This is a new issue that I have experienced. I don´t know if these two issues are related between them but I paste the link here too in case they are.

    Thank you very much


    Plugin Author Joachim Jensen


    As from the previous RUA update, you instructed me to set Tease & Include urls. Now, all these pages are properly set up. The alert of “Not Set” has dissapeared.

    Does all your levels have Non-member action=Tease & include, or do you have any levels with Redirect?
    Have you selected “arquitectura-en-argentina” as the non-member action page for any of your levels? If so, please provide screenshots of the Access Conditions for that level. You can use

    Also, please double check if you have any levels with empty Access Conditions

    I am also having issues with Woocommerce where download link shows errors, ( )

    Unfortunately I am not able to view this page. I am redirected to

    Thread Starter aflorarte


    Hello, Joachim and thank you for your response

    I will try to answer step by step

    Regarding the bad link, sorry for my mistake. The correct link is
    I share with you the ticket placed in Woocommerce because this Woocommerce issues showed up as of the moment I made these changes in RUA settings

    Does all your levels have Non-member action=Tease & include, or do you have any levels with Redirect?

    There were no Redirects: At the moment of the issue All Access Levels were properly configured to Tease & Include.  

    Now, prior to this issue, yes, there had been Redirects to 3 Access Levels (redirecting to “arquitectura-en-argentina” 

    So sorry as I must have misunderstood  your instructions in ticket, where you wrote

    “If you have any levels that do not have any Access Conditions/Capabilities, they are redudant and will likely interfere with other levels.
    You should be able to safely remove any level with 0 access conditions and capabilities. Generally, you only need access levels for users who you want to have exclusive access to something.E.g. if you have some content you don’t want logged-out users to see, you should create an access level for logged-in users and add the content to that level.”

    After that ticket I removed those levels and after having removed them, strangely enough redirection still persisted. (even when, as I say, all Redirects had been removed.  No red alarms of “Not Set” were showing

    By that time I had 3 levels with access to all pages and posts except for restricted content. After your explanation, I understood that I had to remove them because of possible conflict risks.  Today, they are re-enabled  and  luckily, the redirection issue has been fixed.  These 3 levels do redirect to “arquitectura-en-argentina”  They are “Subscriber” “Client” and a new one which showed up in the list (not logged in-Level Name 5958-) Their settings are identical,
     I hope this does not cause any further issues. Please clarify this for me,  

    I´m so sorry as RUA updates get me confused.

    Do I now have to set LOGGED IN in all levels?? Or is this not necessary.  In

    You explained “Existing levels configured with Syncrhonized Role will continue to work as is” but I don´t know if things have changed so far. 

    After having re-enabled the 3 ACcess levels I mentioned above, things seem to be working fine again,  However, in order to avoid any further— and because I find it complicated to explain my doubts,— please let me show you the 3 points I have doubts about in the following screenshots 

    CLIENT , SUBSCRIBER, not logged in-Level Name 5958- SETTINGS

    I hope you can help me clarify this and fix whatever needs to be fixed. 

    Thank you very much for your patience!


    P.S: I found that if links don´t work, this is solved by clicking on them again. So sorry about this

    • This reply was modified 2 months, 1 week ago by aflorarte.
Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.