[resolved] Redirection into a Multisite (4 posts)

  1. PetLvr
    Posted 5 years ago #

    I've got two domains .. let's say realdomain.com is where the site is and let's say similardomain.com is just a registered domain.

    What I normally do ... is I would go into my cPanel of realdomain.com and add as parked domains the similardomain.com

    So, when I typed in the URL similardomain.com .. it doesn't redirect to realdomain.com .. but instead operates the realdomain.com as similardomain.com. So, pages like similardomain.com/about/ etc all work no problem.

    (example... PetLvr.org is a parked domain for PetLvr.com and will continue to work for all pages http://PetLvr.org/blog/ until a new link is clicked and then revert back to the .com URL). I've been doing this for a while now (the .net, .org, etc TLD's to my larger domains) and don't even know if this is the best way, although my host provider suggested it and it works.

    Now - I come to do the same on realdomain.com - which is a 3.0.1 multisite ... and when you type in similardomain.com .. it gives me this URL instead...

    > and an error message because I have my network options to deactivate registration.

    Any ideas how I can get this to work?


  2. that technique would work on the member blogs with the domain mapping plugin, but - as you can see - not the main blog.

    that "error" basically means it's trying to look up a non-exisiting blog in the database. there's no record for that domain, so it flips to the signup page.

    You can put in
    define( 'NOBLOGREDIRECT', 'http://yourdomain.com/' );
    in the wp-config.php file.

  3. PetLvr
    Posted 5 years ago #

    Thanks Andrea.

    I tried that inclusion last night, but didn't include the http:// for some reason and I was getting this error message:

    The page isn't redirecting properly
    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.
    * This problem can sometimes be caused by disabling or refusing to
    accept cookies.
    Try Again

    But, then I tried it again after reading your reply WITH the http:// and it's working fine!

    It's odd because there is a line in there also without the http://
    define( 'DOMAIN_CURRENT_SITE', 'yourdomain.com' );

    All's well that ends well :)

    Take care

  4. It's odd because there is a line in there also without the http://
    define( 'DOMAIN_CURRENT_SITE', 'yourdomain.com' );

    Different command tho. ;)

Topic Closed

This topic has been closed to new replies.

About this Topic