Support » Plugin: Page Links To » Redirection doesn't function with newest version (2.9)

  • Resolved leanderbraunschweig

    (@leanderbraunschweig)


    Hey there!

    Love your plugin, awesome functionality. Since the latest update though, my redirects stopped functioning = the pages reverted to showing the original WordPress-content, not the static pages I’ve setup for them.

    I deleted all the caches (got W3 running), updated the corresponding pages again and cleared my browser caches as well but it didn’t work. We got a multi-server-setup in place but since the last version did the trick, I don’t think this could be an issue now – although you refer to a massive code refacturation…

    Any ideas / hints on what to do or how to debug? I went back to 2.8 and all is good again…

    Thanks & regards!
    Henning

    http://wordpress.org/extend/plugins/page-links-to/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Yes, there is a bug in latest version.

    On line 413 & 416 in page-links-to.php you can change “$wp_query->post_ID” to “$wp_query->post->ID”.

    Plugin Author Mark Jaquith

    (@markjaquith)

    WordPress Lead Dev

    Doh. Just pushed version 2.9.1 to fix this. Thanks for the report! I’ll add a unit test so this bug doesn’t happen in the future.

    leanderbraunschweig

    (@leanderbraunschweig)

    Thanks for the swift fix!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Redirection doesn't function with newest version (2.9)’ is closed to new replies.