WordPress.org

Forums

qTranslate
Redirecting to default language (6 posts)

  1. R22
    Member
    Posted 1 year ago #

    Hello,

    I have installed qtranslate plugin 2.5.38 and I have one problém. I want to have my website in 2 languages – English (default) and Arabic. The issue I have is, if I switch language to the Arabic (by clicking on the flag), it switches corectly, but if I go to another page/post/custom post/homepage it automatically switches back to default language.

    You can see it here - http://rosta.sperkobchod.cz/travel/wordpress/facilities/spas-in-czech-republic/
    When you switch to the arabic version (the flag is in the footer), it switches properly. But if you click on any other link on the site, it redirects you to english version of that page (the website isnt actually translated yet, but you can just look to URL). If you hover on the link of any other page, you can see there is no „/AR/“ in URL. How can I fix it pls? It is the only issue I am experiencing with your great plugin.

    My WP version is 3.8
    Theme is mine (I coded it)
    I use wp_nav_menu for created menus

    If you need any other info I will provide it. I would be hugely grateful if you could help me.

    Thank you so much,

    R22

    http://wordpress.org/plugins/qtranslate/

  2. ajogminas
    Member
    Posted 1 year ago #

    Hello,

    I do have the same problem. qtranslate is working correctly until I am going to the sub page's (www.name.com/page1/page2 - here it goes back to default language)

    My WP version is 3.8
    qtranslate version 2.5.38

    Any help?

  3. belenxi
    Member
    Posted 1 year ago #

    Got exactly the same problem!! And I don't know how to fix it...

    It seems that since bloginfo('template_url') is a real path in fact, it doesn't work with "/en/" (or any other) in front of the pages' links. I've tried to use echo home_url(); and then add afterwards the language "/en/" + the structure of sections "/page1/page2/page3". But nothing.

    Any help?? :)

  4. belenxi
    Member
    Posted 1 year ago #

    OK, I got the answer finally ;)

    I was wrong using the setting "Pre-route" (by default, adds /es/ before the URL) in Advanced Settings inside qTranslate Options. So, using bloginfo('template_url') every link always took me to the default language...

    Now that I just changed to the 3rd option in Avanced Settings, (add in the end ?lang=xx) everything works fine because I can still use href="<?php bloginfo('template_url'); ?>/mysubpage/?lang<?php echo qTranslate_GetLanguage(); ?>"

    Hope this helps!

  5. Mohammed Thaer
    Member
    Posted 1 year ago #

    You can install Qtranslate Slug this plugin solving evry problem in qTranslate.

  6. robsonrssp
    Member
    Posted 1 year ago #

    I have the same issue. Changing to the third option (add in the end ?lang=xx) instead of addinG /en/ doesn't solve. Where do I need to insert the code below?
    href="<?php bloginfo('template_url'); ?>/mysubpage/?lang<?php echo qTranslate_GetLanguage(); ?>"

    I also installed the Qtranslate Slug, and the problem stills there.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • qTranslate
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.