[resolved] [closed] Redirected to login screen after Multisite install (18 posts)

  1. jonnylons
    Posted 5 years ago #

    I started with a fresh install of WordPress through GoDaddy's application install. Everything was working fine. I then followed the directions to a T from WordPress to upgrade to multisite. I've done this a ton of times before with no problem. When I finish and go to log back in, I enter my PW and am redirected to the login screen again.


    I've done this three times with the same result.

    If I upload the old config file, I can log in with no problem. Once I upload the multisite config we get the loop.

    I called Godaddy and they said everything checks out on their end. They said that WordPress is installed correctly. Again, it's a fresh install and I didn't see any problems.

    But this may be where the problems are. I installed this WP on a subfolder (domain.com/newsite). I then redirected a domain name to this subfolder. No problems though as the new install worked and the domain redirected with no problem. When I go to updgrade, it walks me through the necessary steps and I am able to install subfolder option instead of subdomain.


  2. govpatel
    Posted 5 years ago #

    May be has something to do with installing in directory may it needs to be in root

  3. jonnylons
    Posted 5 years ago #

    No, I've installed outside of the root before.

  4. jonnylons
    Posted 5 years ago #

    Here is the link I am redirected to:


    Any ideas?

    I installed a fresh version of WordPress 3.2.1. I then redirected the domain to the the current subdomain folder. When I type in the new .com it goes to this new install of WordPress.

    Then, once I upgrade to multisite, I can't log in with my admin account. I just get redirected (see the link above).

  5. I installed this WP on a subfolder (domain.com/newsite). I then redirected a domain name to this subfolder.

    FWIW, doing that isn't supported by MultiSite. You CAN do it, but it involves a lot of pokey jiggery that no one's clearly documented, because each server's a bit different.

  6. jonnylons
    Posted 5 years ago #

    I've done it before, using Godaddy as my host. But I am trying to remember how I did it. Wasn't anything extravagant. I think this is what I did:

    I did a fresh install using Godaddy's installation.

    I then redirected my domain to the subdirectory that I placed the fresh install on.

    Next, I then changed the WordPress URL and the Site URL under Settings > General to the domain I want it to be redirected to. All of this worked.

    Then, I did the multisite upgrade. When I tried to login as the admin, I just keep being redirected to the log in screen.

    I got this to work for other multisites but can't get it to work with this one. Like I said, nothing amazing.

  7. That it doesn't work doesn't surprise me. It's not supposed to work. GoDaddy also has some weird rules about MultiSite (like you have to have a dedicated domain).

    Normally if someone was being redirected like that, I'd say to wipe all the cookies and cache from your browser. Also to make sure you did BOTH the .htaccess and wp-config.php changes.

  8. jonnylons
    Posted 5 years ago #

    Thanks Ipstenu for your help, I do appreciate it. It's frustrating because I have done it before and not sure why I can't do it now. I am about to give up and probably just going to have to get a new host for this.

    Yes, I did do both the .htaccess and wp-config mods. In fact, I thought I had found the problem in the config file, but the change I made (to the domain current url) didn't work.

    Nothing revealing in Godaddy's FAQ's either. I think they just set it up in such a way so that you have to pay for a new host.

  9. Dedicated IP, that was the term I was thinking of (dedicated domain? I have no idea what I was smoking).

  10. jonnylons
    Posted 5 years ago #

    I purchased a hosting account - brand new - with Godaddy. Did a fresh install of WP 3.2.1. Logged in as admin, check. Deactivated all plugins, check.

    Upgraded to multisite. Added the first bit of code to the config file:

    define('WP_ALLOW_MULTISITE', true);

    Accessed the Tools > Network. Hit Install and it set me up with subdirectories (can't do subdomains with Godaddy).

    Then added the blogs.dir to the wp-content folder.

    Then added the next bit of code to the config file:

    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', false );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'afirekindled.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    Then added mods to .htaccess:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    FTP's both files into the root directory.

    Go to log in as admin - and STILL get redirected to login screen!


    So, I learned it wasn't a problem installing MS in a subdirectory and then redirecting the domain to that section of the host. It doesn't matter whether or not you get a fresh host or not - you still get the same error.

    The question is, what is causing this error? I've installed MS before many times and have never had this problem. There is something I am overlooking...

  11. Just a quick doublecheck, this IS installed in root, right?

    I've seen two people having this issue with domain mapping, but I don't know if you are doing any at this point...

  12. I've installed MS before many times and have never had this problem.

    was it at the SAME host though? On the same hosting package?

  13. lang.rc
    Posted 4 years ago #

    Same problem here today, clearing cache and cookies resolved the problem.

  14. deernuts
    Posted 4 years ago #


    I am having the same issue after updating the MU Domain Mapping plugin. 5 total domains and 2 are having the issue of the redirecting login screen.


    jonnylons, did you ever figure this out?


  15. deernuts
    Posted 4 years ago #

    I was able to fix this. I moved the sunrise.pgp file to above the last require_once() line in addition to copying the sunrise.php file from wp-content/plugins/wordpress-mu-domain-mapping/sunrise.php to wp-content/sunrise.php.

    Then I made sure that the sites were set up properly within domain mapping (which the 2 were not).

    I think some of the files were re-written with the plugin update and had to re-set up the two sites.

    Hope this can help someone else!

  16. l0gan0
    Posted 4 years ago #

    Clearing my cookies fixed my login issues as well.

  17. jackle99
    Posted 4 years ago #

    Update, I had the issue, was testing sites did a fresh install and got suck with redirecting back to the login page with no errors. Clearing all browser data fixed it for me.

  18. en3r0
    Posted 4 years ago #

    I have to say I did not think clearing data would fix it for me. I cleared the cookies for the domain, didn't work. Tried a different browser (Google Chrome incogito mode) and it did work.

Topic Closed

This topic has been closed to new replies.

About this Topic