Support » Plugin: WP Mail SMTP by WPForms » redirect_uri_mismatch

  • Resolved stevebutler2

    (@stevebutler2)


    Hi, I have just installed the plugin and gone through the authentication for Gmail.

    However, I keep getting an error message when I authorise the app “400. That’s an error.

    Error: redirect_uri_mismatch

    I have copied the URL from the app as shown in the documentation and checked the auth parameters to make sure there is no space.

    Any idea what I am doing wrong, please?

    Thanks for your help.

    Steve

Viewing 9 replies - 1 through 9 (of 9 total)
  • I am getting this error also

    Plugin Author Slava Abakumov

    (@slaffik)

    Hi,

    You might not have actually saved the URL in a project. You need to add it and then save, it will require 2 steps to add. You can check that it persists by doing a page refresh.
    It should look like this AFTER page refresh with your domain: http://cloud.supportally.com/eba75054675c

    I am having this same problem. I have confirmed the URI is saved and authorized, but the smtp plugin keeps giving me this error.

    (UPDATE:) Its working. Just took a very long time for google to see it. Also helped to open a private browser window to get around the cache.

    • This reply was modified 1 year, 5 months ago by VanAwful.

    I have this exact problem with error message in the final step after clicking the orange button “Allow plugin to send emails…”

    This thread gives me a hint. It turns out, this is bad user UI on Google end. After entering the URI in the Authorized redirect URIs under Google account, little I knew that you would need to hit the enter key ‘before’ hitting the Save button. The Save button is confusing to make you think you are really saving the settings.

    You may want to emphasize this little part in documentation to save some headaches.

    Plugin Support Jess Quig

    (@jquigam)

    Hi skylabb,

    I wanted to let you know we’ve added a note about this in our Gmail SMTP doc. Thanks for catching this!

    simonelourens

    (@simonelourens)

    Hi, I have this error also. I was trying to set this plugin up for someone last week and they were not able to verify in time, so I’m thinking it may have timed out. I set up a new project but neither the earlier one or the new one will load. Just get the above error?

    Arjan Nadorp

    (@arjan-nadorp)

    Im stille having a 404 error

    https://www.deknollentrekkers.nl/wp-admin/admin.php?page=photonic-auth&source=google&state=87629bce2844ac87de24b0f16da68d10::%252Fwp-admin%252Fadmin.php%253Fpage%253Dphotonic-auth&code=4/vAHd3STY2tTxn38XQEzMvbQYFF8NDJFf0sAZhTTG_LLV314yZ6ozV3qnub0zBXReWQdg6KtrPAz6p_Snm2Q8vE8&scope=https://www.googleapis.com/auth/photoslibrary.readonly

    Plugin Support Sanjeev Aryal

    (@sanzeeb3)

    Hi @arjan-nadorp,

    I apologize for the trouble. Are you getting this when you allow Google to send emails on the behalf of your account and returning back to the settings page? Could you please share the steps or record a screencast video when you’re getting this error?

    This will help us to know what might be going on! 🙂

    Thanks!

    reubensh

    (@reubensh)

    I’ve just managed to fix this problem.

    I did yesterday all the steps to “Create a Web App in Your Google Account” and it wall worked well, successfully sending the test email.

    Today I entered the plug in on my wordpress dashboard and received an error. Then saw that the Client Id and Client Secret boxes were empty.
    So went to my google API’s to copy them again. Then received the “redirect_uri_mismatch” error while trying to authorised.

    I went back to Google API’s and deleted the Authorized redirect URI.
    Then I simply put again the URL there and saved.

    Went back to wordpress admin, clicked on the authorization button and finally it worked.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.