Support » Plugin: Redirection » Redirect / www

  • Resolved amichaelwagner

    (@amichaelwagner)


    Morning!

    Just noticed a new behavior that didn’t happen before: Whenever my redirected links include www (e.g., ‘www.easiercast.com/29’), they land on the admin login page. But, when they have no www, or they include https://, the redirect works properly (e.g., https://easiercast.com/29).

    Any idea what could be causing this?

Viewing 15 replies - 1 through 15 (of 30 total)
  • Plugin Author John Godley

    (@johnny5)

    I’m not seeing this behaviour when I access http://www.easiercast.com/29 – did you resolve the problem?

    amichaelwagner

    (@amichaelwagner)

    Two things: First, it’s still happening on my end, both on desktop and mobile.

    Second, just to be sure: Did the forum add the “http://” to the link you typed? Just wanted to be sure!

    amichaelwagner

    (@amichaelwagner)

    In another thread, I saw that you mentioned the Force HTTPS option. I just tried disabling that, and it put the page through properly.

    I’d definitely like to keep this enabled if possible, though.

    Problem is, whenever links are entered without HTTPS explicitly stated, they redirect to HTTP. Is there any way to fix both?

    Try “easiercast.com/27” (used quotes so the forum wouldn’t tack on the HTTP)

    (FYI, I’ve disabled the Force HTTPS option for now, in case you’re testing using my site. Figured I’d rather have folks directed to a page marked Not Secure than to the Login page.)

    Plugin Author John Godley

    (@johnny5)

    amichaelwagner

    (@amichaelwagner)

    I just updated my previous suggesting you try “easiercast.com/27” — it happens there but not on /29 for some reason?

    Plugin Author John Godley

    (@johnny5)

    “easiercast.com/27” used quotes so the forum wouldn’t tack on the HTTP

    A URL either is either http or https. Your browser will automatically add these if you don’t, so it makes no difference putting quotes around it here.

    It works fine with either:

    https://redirect.li/http/?url=http%3A%2F%2Feasiercast.com%2F27

    Are you logged in? This is very likely specific to you being logged.

    amichaelwagner

    (@amichaelwagner)

    Hm, being logged in/out doesn’t seem to affect it. Logged out and flipped over to an Incognito window. /27 still redirects to an HTTP page and the browser flags it as not secure.

    Screenshot: https://drive.google.com/open?id=1z40LXXt69Bc8AK1OumOLevlUfjZw1yOD

    Plugin Author John Godley

    (@johnny5)

    Your original message stated that the problem was to do with being redirected to /wp-admin/. Is this not the case?

    amichaelwagner

    (@amichaelwagner)

    Right, that was the original problem for sure. But, after researching through the forum, I saw that you mentioned the Force HTTPS option potentially being the cause. So, I disabled that option, which solved the /wp-admin problem.

    Now though, as a result of that, pages are redirecting to HTTP and not HTTPS. So, it’s caused a new, but related problem.

    Plugin Author John Godley

    (@johnny5)

    Ok, then that’s not a problem – you’ve disabled the feature, so it won’t work. If you want to force https then you’ll need to re-enable the option and we can look at the issue again.

    I’m having this same exact issue. Any fix to this? You didn’t real answer Michael’s question at all.

    EDIT: I found a solution for myself. Hopefully this will also work for you since you haven’t be able to get much information. Keep the Force HTTPS on.

    Add a new redirect with these settings:
    Source URL: ^/(.*)
    Match: URL and Server
    Server: https://www.yourwebsite.com
    When matched: Redirect to URL with HTTP code 301 – Moved Permanently
    Matched Target: https://yourwebsite.com/$1

    This should work for you since I had the exact same issue. Let me know if it doesn’t!

    • This reply was modified 11 months, 3 weeks ago by mcneiljv.
    • This reply was modified 11 months, 3 weeks ago by mcneiljv.
    Plugin Author John Godley

    (@johnny5)

    @mcneiljv you seem to be redirecting www traffic to non-www, which looks like a different issue.

    @mcneiljv Thanks so much for that! I appreciate you trying to help, despite this feed not being exactly about its title…

    So, I’ve tried the settings, but www. URLs still redirect to the login page (with Force HTTPS on).

    Plugin Author John Godley

    (@johnny5)

    @amichaelwagner if your problem is with the force https option then that is something I am trying to debug. I am unable to reproduce the problem myself, and I’ve yet to track down a site with the problem that I can test. If you have a site that I can look at then I’d be keen to try and figure out what is happening.

    @johnny5 It’s with both. One problem impacts the other. I made the decision that I’d rather traffic be referred to the HTTP version of my site, as opposed to the login page.

    I’m happy to turn the setting back on now so that you can troubleshoot with my site, if you’d like.

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘Redirect / www’ is closed to new replies.