Support » Plugin: User Access Manager » Redirect user

  • Resolved scanomat

    (@scanomat)


    When i choose the “Hide posts” element, and i send an email out with a link to the locked posts, it just sends the users to a 404 page. I would very much prefer a redirect to the start page or similar.

    Redirect user is something you have implemented under the “settings” pane, problem is that it doesnt work….

    I have setup the redirect, but it still just gives the users a 404 page.

    Any ideas ?THanks

    http://wordpress.org/extend/plugins/user-access-manager/

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author GM_Alex

    (@gm_alex)

    If you completely hide the post/page you only get an 404 that nobody can recognize that there is an post/page, but I will add this feature to a future version. So it’s no bug but at the moment I changed this to resolved.

    Dear Alex,

    Its very odd, not being able to hide a post, and just redirect people to the simple frontend page or a login page.

    It is a feature, which we are a need off, specially as the rest of your plugin is amazing!

    Please could you sneak this in very very soon ?!

    Thank you.

    Plugin Author GM_Alex

    (@gm_alex)

    Please try the new version 1.4.2.2. It should work there.

    I have just updated to the lastest 1.2.4.2 – and when i set the setting to : Redirect user to custom page.

    It still gives me an 404 error: http://intranet.scanomat.net/sommerfest-grillparty/ you can test it here.

    Plugin Author GM_Alex

    (@gm_alex)

    You could test again, found a possible solution in 1.2.4.3.

    Greetings,
    Alex

    Still doesnt work. Sorry for the slow response, we had a few national holidays.

    Hey Alex,

    Thanks so far, havnt heard anything from you! please let me know if i can help in any way.

    Hello sir, anything new?

    Might this help? I came across Fix for User Access Manager for WordPress today.

    “If you happen to be using the “User Access Manager” in your WordPress install, and you are using Permalinks, then you will need this fix. Without it, the redirect for logged out users won’t work, and they’ll end up on a 404 page.”

    http://www.outofcontrol.ca/thoughts/comments/fix-for-user-access-manager-for-wordpress

    Thank you Teresa,

    though this does not fix my case, did it fix yours if you had the same problem?

    Hi Alex,

    Unfortunately the latest release doesn’t fix this issue. It still remains.

    G

    @wealthcop

    (@teresa_lo)

    Scanomat – still no luck. The best I can do is UAM > Settings > Other Settings > Redirect User > to Custom Page (from drop down menu) OR Custom URL….

    HOWEVER … the neither of these settings actually redirects the user to the custom page or the custom URL, but instead to /wp-login/ (which is better than 404).

    🙂

    @wealthcop

    (@teresa_lo)

    Perhaps the redirect functions for only one type of permalink. But which one?

    1 Default
    2 Day and name
    3 Month and name
    4 Numeric
    5 Post name
    6 Custom Structure

    Maybe Alex will let us know. Or maybe only if the pages are all in one category. Who knows?

    @wealthcop

    (@teresa_lo)

    Or, you never know … perhaps UAM redirect conflicts with another plugin.

    I use Login Redirect so that might be the culprit. I might try disabling Login Redirect and then see if UAM does the Custom Page/URL redirect thing properly.

    Login Redirect

    erna.braat

    (@ernabraat)

    Hello Alex, Scanomat, Lordg, Teresa_Lo,

    I have the same problem using version 1.2.4.3 and I do not use Login Redirect plugin.
    I tried to set a custom page or custom url but users are still redirected to 404. If this option doesn’t work yet I would be glad if users were redirected to wp-login instead.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Redirect user’ is closed to new replies.