Support » Plugin: Ultimate Member – User Profile, User Registration, Login & Membership Plugin » Redirect to specific page doesn’t work for restricted content

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support mansurahamed

    (@mansurahamed)

    Hi @wiebe1996,

    If this doesn’t work with some of the pages that means other plugins are using codes/ filters that is hampering/conflicting with um content restriction. Can you do a conflict test and see if the issue goes away? This doc explains how to do a conflict test if you are not sure: How to do a plugin/theme conflict test?

    Thanks.

    Thread Starter wiebe1996

    (@wiebe1996)

    Dear mansurahemed,

    Thanks for your response, i did a plugin/theme conflict but I still get the ‘not found’ page now in the WordPress default theme. The redirect function works well on all pages but it does not work with blog posts. Hope you can help me out.

    Gr, Wiebe

    Plugin Support mansurahamed

    (@mansurahamed)

    Hi @wiebe1996,

    Please go to Ultimate Member->Settings->Access->Enable the “Content Restriction” settings for post types, inside your dashboard and make sure to check “Post” there. If you are still having trouble, please install Ultimate Member in a fresh wordpress installation and try to replicate this issue there.

    Thanks.

    Plugin Contributor Champ Camba

    (@champsupertramp)

    Hi @wiebe1996,

    This thread has been inactive for a while so we’re going to go ahead and mark it Resolved.

    Please feel free to re-open this thread by changing the Topic Status to ‘Not Resolved’ if any other questions come up and we’d be happy to help. 🙂

    Regards,

    Thread Starter wiebe1996

    (@wiebe1996)

    Dear Champ Camba and mansurahamed,

    I found the issues, it was solved because we use our blogs as a homepage and there was a setting to show not logged in users a 404-pages on the category setting. I changed this to redirect to login page and it was fixed.

    Thanks a lot for your help!

    gr, Wiebe

    Plugin Contributor Champ Camba

    (@champsupertramp)

    Hi @wiebe1996

    Thanks for letting us know how you’ve resolved the issue.

    Regards,

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.