• Resolved marcorroma

    (@marcorroma)


    Hi, I’m using a plugin to duplicate a post every day, “Duplicate Page or Post” plugin, ver 1.1.6.
    The duplicate post has the same slug as the original post, with the addition (from WordPress core) of -2. To distinguish the two posts.
    Having worked fine for the first two duplicates, I now have a problem.
    Opening the post will redirect you to the homepage from your plugin (redirect 301), if you are not logged in.
    If you are logged in, the post is displayed correctly, without redirects.

    How come I have this problem?

    Edit. I just noticed that the post was duplicated twice today. one post was kept as a “draft”, the other post was published. I deleted the “draft” post, cleared the cache, and the problem is solved.
    But how come I had this problem only for non-logged in users? I also tried clearing the cache, but I always had redirects. As if it were a 404 page with redirect to the homepage (as per your plugin settings)

    Thanks for support.

    This is the HTTP Headers:

    >>> https://www.mywebsite.com/slug-my-post-2-2-2/
    
    > --------------------------------------------
    > 301 Moved Permanently
    > --------------------------------------------
    
    Status:	301 Moved Permanently
    Code:	301
    Content-Type:	text/html; charset=UTF-8
    Expires:	Wed, 11 Jan 1984 05:00:00 GMT
    Cache-Control:	no-cache, must-revalidate, max-age=0
    X-Redirect-By:	Rank Math SEO
    Location:	https://www.mywebsite.com/
    X-Litespeed-Tag:	080_HTTP.404,080_HTTP.301,080_404,080_URL.e4710d489537ab25faf62f785b63a336,080_
    X-LiteSpeed-Cache:	miss
    Content-Length:	0
    Date:	Sat, 24 Apr 2021 18:26:33 GMT
    Server:	LiteSpeed
    Alt-Svc:	quic=":443"; ma=2592000; v="43,46", h3-Q043=":443"; ma=2592000, h3-Q046=":443"; ma=2592000, h3-Q050=":443"; ma=2592000, h3-25=":443"; ma=2592000, h3-27=":443"; ma=2592000
    Connection:	close
    
    >>> https://www.mywebsite.com/
    
    > --------------------------------------------
    > 200 OK
    > --------------------------------------------
    
    Status:	200 OK
    Code:	200
    content-type:	text/html; charset=UTF-8
    Link:	<https://www.mywebsite.com/>; rel=shortlink
    vary:	Accept-Encoding
    server:	LiteSpeed
    alt-svc:	quic=":443"; ma=2592000; v="43,46", h3-Q043=":443"; ma=2592000, h3-Q046=":443"; ma=2592000, h3-Q050=":443"; ma=2592000, h3-25=":443"; ma=2592000, h3-27=":443"; ma=2592000
    X-LiteSpeed-Cache:	hit
    Date:	Sat, 24 Apr 2021 18:26:33 GMT
    Connection:	close
    
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Rank Math

    (@rankmath)

    Hello @marcorroma,

    Thank you for contacting the support and sorry for any inconvenience that might have been caused due to that.

    It seems to be working fine on our end.
    https://i.rankmath.com/NV0kAr

    Assuming you are using the latest version of all the plugins, themes, and WordPress (please update if not yet), it would seem like a conflict with one of the plugins or the theme you are using.

    To determine that, please follow this troubleshooting guide:
    https://rankmath.com/kb/check-plugin-conflicts/

    Only the site admin would know and your users won’t be affected by this troubleshooting.

    Also, maybe server cache is enabled on your site. You can also try updating the permalink Settings to flush the rewrite rules.

    Hope that helps.

    Thread Starter marcorroma

    (@marcorroma)

    Hi, I have the most recent version of WordPress, and plugins.
    The cache is not enabled for logged in users.
    The duplicate post must be created as a “draft”, these are the settings of the plugin to duplicate posts:
    https://i.ibb.co/s65Msm4/post-dup-set.png

    You then have to “move to the trash” the duplicate post. Then you duplicate the post again (from the original post), and try to view it.
    Probably a rule is created that is not removed when you “move to the trash” the post.

    Can you try again with this setting?
    Thank you

    Plugin Author Rank Math

    (@rankmath)

    Hello @marcorroma

    We still couldn’t reproduce this issue on our setup even after changing the Duplicate Post status to draft from Duplicate Post settings. Please check this screencast:
    https://i.rankmath.com/zerYq0

    Please note, WP will show 404 error for draft posts for non-logged in users. After duplicating the post, we published it and it worked well.

    Hope that helps. Thank you.

    Thread Starter marcorroma

    (@marcorroma)

    It happened again (with pages).
    I was working on an important page on my site, before the edit I decided to create a duplicate page (if I wanted to recover some material from the previous version).
    The duplicate was created as a draft, and remained as a draft.
    If logged in I was viewing the correct page. I cleared the cache, displayed as not logged in, and had a redirect to the homepage (as per rank math settings).

    Screenshot:
    https://i.ibb.co/9Y3jc47/red.png

    I opened the duplicate (the draft) and the slug is the same as the original content. So it went into conflict.
    I moved the draft to the trash.
    I converted the original page into a draft, then re-published. WordPress changed the slug automatically, I restored it as it originally was. And so now it works (after clearing the page cache).

    It seems as if Rank math creates this problem, because it redirects every unknown page to the homepage.

    How can I solve this problem?

    Plugin Author Rank Math

    (@rankmath)

    Hello @marcorroma

    Can you please follow this troubleshooting guide?
    https://rankmath.com/kb/check-plugin-conflicts/

    Also, please record the screencast with a free service like Loom. Disable all the other plugins except Rank Math and the plugin you are using to duplicate the posts.

    Looking forward to helping you. Thank you.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.