WordPress.org

Support

Support » Plugins and Hacks » [Resolved] redirect problem

[Resolved] redirect problem

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Josh Kohlbach

    @jkohlbach

    Hi hanshans,

    This typically occurs when another plugin or theme flushes the redirect rules incorrectly, this should only be done during plugin activation/deactivation.

    Please try the following:

    1. Deactivate ThirstyAffiliates, don’t worry your links are safely stored in the database.
    2. Reactivate ThirstyAffiliates
    3. Visit the Settings->Permalinks page and click save (ensure your .htaccess file is writable by the web server).
    4. Go back to ThirstyAffiliates->All Affiliate Links and view one of the links, it should be redirecting properly.

    Failing this, you can test deactivating your other plugins one by one to see if you can find the conflict.

    1. Disable suspect plugin
    2. Visit Settings->Permalinks page and click save (ensure your .htaccess file is writable by the web server).
    3. Goto ThirstyAffiliates->All Affiliate Links and click view on one of your affiliate links to see if this fixed it.
    4. If that didn’t fix it, you can reactivate that plugin and try the next.

    Hi jkohlback,

    Have been looking forward for a response. Thanks for your explanation!

    It’s prettty strange, I tried thirsty affiliates again today and it immediately worked. Don’t know why, it’s weird. But it’s okay now:)

    So thanks again!

    Hans

    Plugin Author Josh Kohlbach

    @jkohlbach

    No worries, I’d say it was one or a combo of permalink issues.

    It’s quite a common problem with WordPress plugins that do funky things with custom post types 😉

    Glad it’s working for you now!

    Hi-
    I tried your wp plugin and I wanted to know if there is any prior preparation necessary like transferring files using ftp in my cpanel to make the plugin work. I am a newbie and I don’t know how to do that stuff. I set up your plugin, but it just did not cloak the affiliate link. It showed the entire account link in the address bar. Please help me :o(
    Thanks
    Janie

    This plugin doesnt work with 3.8.2 version.

    Plugin Author Josh Kohlbach

    @jkohlbach

    Hi hdalive,

    Please post a new topic with your bug report, I won’t see them if you just hijack old thread (plus it’s against the WP.org forum policies).

    To answer you question, we found a bug this morning which was exposed with the recent 3.8.2 update to WordPress.

    We have released a new version of the main ThirstyAffiliates plugin this morning that fixes the issue (2.4.1).

    My apologies for any inconvenience. Please update to the latest version as soon as you are able.

    Hi jkolbach,

    I followed your instructions above but am still unable to get the thirsty affiliate links to work. The theme I’m using is the Templatic–>Directory–>YellowPages Theme and it does use a custom post type. Can you point me in the direction to get ThirstyAffiliate links working?

    It seems like the theme is taking over the redirect and somehow determines it is not a valid link and gives a “page not found” message.

    Plugin Author Josh Kohlbach

    @jkohlbach

    Hi extremehoteldeals,

    Is your .htaccess writable by the server? Ensure there are no warnings about that not being writable on the Settings->Permalinks page.

    Also, you can try to temporarily change your theme, clear permalinks again, then test ThirstyAffiliates links to see if that actually is the problem. That will help you eliminate the theme if that is the issue.

    Cheers,
    Josh

    Hi jkohlback,

    Thank you for getting back to me. The Settings->Permalinks does not display any warnings.

    So I went ahead and changed the theme and deactivated every plugin. Then followed your procedure above. Unfortunately I still cannot seem to get the Thirsty Affiliates Plugin to work. The redirect ends up something like if I wanted slug “test” to redirect to “www.google.com”

    http://website.com/go/test/ -> http://website.com/go/test/www.google.com

    Plugin Author Josh Kohlbach

    @jkohlbach

    You’re missing the http:// from the destination URL. All URLs must start with a http:// or https://

    Cheers,
    Josh

    Ah! Well that fixed it when I deactivated every plugin but Thirsty Affiliates. However now I activate the other plugins one-by-one (required by the theme) and the first one I add still seems to break Thirsty Affiliate’s redirect.

    My inkling is that the custom post types of the theme are conflicting with the Thirsty Affiliate’s plugin. Is there a place I should be looking at to see how URLs are interpreted and which ones have precedence?

    I do appreciate the help jkohlback!

    Plugin Author Josh Kohlbach

    @jkohlbach

    Hi again extremehoteldeals,

    What is name of the plugin that is causing it to break? Is it a free one or premium with the theme?

    You can use something like Monkeyman Rewrite Analyser to test which rules are taking precedence.

    Cheers,
    Josh

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] redirect problem’ is closed to new replies.