WordPress.org

Forums

Redirection
Redirect Only Works After 404 Generated (2 posts)

  1. relish1227
    Member
    Posted 12 months ago #

    I've used this plugin in the past and it is great. However, I'm having an odd issue here.

    + I imported about 500 redirects in.
    + I then started testing out the redirect by copying in the "source URL" into the browser.
    + Unfortunately, it goes to a 404 page.
    + I then check the 404 list within the Redirection plugin.
    + I find my page there and hover over it so I can click on the "Add Redirect" link.
    + I add the redirect again this way.
    + When I test it, it works!

    I have copied and pasted both source URLs -- the one from the import and the one I manually added -- into a file so I can compare them... and they are the same! Why would this be? Is there anything else that could be causing this to not work?

    Thanks.

    https://wordpress.org/plugins/redirection/

  2. relish1227
    Member
    Posted 12 months ago #

    After doing some searches, I found people talking here -- http://wordpress.org/support/topic/redirection-not-working-when-redirect-from-non-wordpress-site-to-wordpress-site?replies=4 -- about how this doesn't work when the source URL is a non-Wordpress URL. In my case, the old URLs are .asp pages. Perhaps this explains the weirdness I'm seeing here?

Reply

You must log in to post.

About this Plugin

  • Redirection
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic