Viewing 3 replies - 1 through 3 (of 3 total)
  • My login page is also not redirecting. I replied to someone else here last week: https://wordpress.org/support/topic/how-to-remove-user-view-when-you-are-already-logged-in/#post-10383207 still waiting for a response from UM 🙁

    Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @dalaboy77 and @ridethetides,

    Firstly, please check your user role setting – “Action to be taken after login” and make sure that you’ve set redirect correctly, you can try to add full URL.

    Secondly, your page should be accessible to your subscriber user role. Check the page access settings.

    Try to do a conflict test so we can rule out conflicts with other plugins or your theme and see if it helps. Here is the doc on how to do a conflict test.
    If you have any caching plugins or server side caching please exclude Ultimate member pages from the cache.

    Regards.

    Thread Starter Dav

    (@dalaboy77)

    Many thanks for your reply! Yes, I checked all that previously, and all that is working. I guess I must have more clearly put my question. I wanted the user to be redirected to the referral page after login.

    Here is the sequence: 1) The user is on one of my blog post pages (https://www.freelogica.kz/chto-takoe-freelogica/). In order to comment she needs to log in. 2) The user clicks on ‘Please log in to comment’ and is taken to my site’s login page (https://www.freelogica.kz/login/). 3) After logging in I would like the user to be taken back to the blog post page (https://www.freelogica.kz/chto-takoe-freelogica/).

    But instead of that the login page gets refreshed and the user avatar is shown.

    I think I understand why it could be happening. In order to replace the WordPress default login page, I inserted the below filter into the functions.php of my theme (Customify):

    add_filter( 'login_url', 'my_login_linkchanger');
    function my_login_linkchanger( $link ) {
      /*whatever you need to do with the link*/
      return home_url( '/login');
    }

    So, when I use the ‘Refresh active page’ option, it refreshes this login page.

    Do you think that is the problem? If yes, do you think there is a way around this? In other words, I would still like using my custom /login page for login, and have the user redirected to the referral page (which I cannot set to one specific URL because obviously the user can come from any blog post page).

    Million thanks for the amazing plugin!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Redirect on Login page not working’ is closed to new replies.