WordPress.org

Forums

MobileESP for WordPress
[resolved] Redirect of Posts (5 posts)

  1. windstyles
    Member
    Posted 1 year ago #

    This plugin works like a champ for redirecting our mobile users and also, your info on how to allow them to view full site works great.

    However, if our mobile users view full site and then try to read posts, it switches them back to the mobile site. Pages work fine, but posts redirect. The posts links are in a widget, if that matters.

    How can we prevent this from happening? Thank you!!

    http://wordpress.org/plugins/mobileesp-for-wordpress/

  2. BandonRandon
    Member
    Plugin Author

    Posted 1 year ago #

    Sounds like it could be a cookie issue. It seems that somehow the mobileesp_wp_full_site cookie is getting unset when they are clicking on the post.

    Are you able to post (or email me) a URL to your site?

    Are the post and pages on the same domain?

    It it only happening when they click a link in the widget or also when you manually enter a post URL?

    If you visit example.com/post?mobileesp_wp_full_site=true do you still have a problem?

  3. windstyles
    Member
    Posted 1 year ago #

    Thank you!! The full site is flow-riteplumbing.com
    The mobile site is m.flow-riteplumbing.com

    Truly appreciate your help!! :)

  4. BandonRandon
    Member
    Plugin Author

    Posted 1 year ago #

    I have set up a test installation and can't seem to duplicate this problem at all. Do you have any other plugins that may be conflicting?
    Especially plugins that are regarding permalinks/redirection. I think it must have to do with the way you have the post set up or it's a plugin conflict.

    Did you delete the old redirect code from this post: http://wordpress.org/support/topic/added-character-on-posts in your index.php? If you still have the redirect code in your index.php it would be causing this issue. I'm 78% sure this is your issue.

  5. windstyles
    Member
    Posted 1 year ago #

    THANK YOU!! That was it. I removed the old redirect code from index.php and now it is working perfectly. Thank you for your help!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • MobileESP for WordPress
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.