WordPress.org

Support

Support » Plugins and Hacks » Redirect not working for non admin users

Redirect not working for non admin users

Viewing 15 replies - 1 through 15 (of 29 total)
  • angelo_nwl
    Participant

    @angelo_nwl

    hi,

    I tried this one and seems to be working fine; Is that using redirection settings at WP Settings > Login With Ajax and are you using version 3.1.2 ?

    lorembolo
    Member

    @lorembolo

    hi,

    it really doesn’t work for me. I configured everything in settings–>login with ajax, but every user (except admin) is not redirected.

    yes, I use 3.1.2

    lorembolo
    Member

    @lorembolo

    Somethnig else : when registering, the error is the same. I got the waiting animation looping but no confirmation message. Maybe a JS issue?

    edit : no, cause it works for admin.

    Plugin Author Marcus
    Participant

    @netweblogic

    will test this out and get back to you asap (will need a week or so)

    lorembolo
    Member

    @lorembolo

    thx a lot.
    If it can help, it seems to be caused by some conflict with s2Member.
    It works fine if I uninstall s2M…

    Dimitris73
    Member

    @dimitris73

    Hello and thank you for this plugin.
    I have exactly the same issue with lorembolo. I am using s2Member too.

    Plugin Author Marcus
    Participant

    @netweblogic

    haven’t tested it yet, but it may well have to do with the fact that s2Member also redirects on login, that may be taking priority.

    e.g. in settings – Login Welcome Page

    Hello,

    i have a similar problem… i use ajax with login with s2member together.

    Until now it worked fine but since the last update (?), when a member tries to log in, the preloader does not stop turning. Some members can log in finally by escaping the log in page and going to another one (no redirection), some of the members can not log in at all…

    Admin can log in without difficulty.

    Do not forget that this plugin worked with s2member very well before.

    Waiting for the news and solutions and thank in advance !

    I would like to add some other information… it seems that something happened with some members since this incident exists.

    I have two websites, one works since one year, the other one is under construction. For both i use LWA plugin and s2Member plugin.

    I created a Test profile in the new website to see how the member sees it. But since LWA plugin does not work properly, i can not log in with the Test username and keyword.
    In the meantime, a member of the existing (older) website said that he can not log in anymore. I tested his log in and it has the same problem like Test member on the other website.
    I tried to change their password, it does not work, those members are completely blocked.

    advaitavs
    Member

    @advaitavs

    I am having same problem.

    I am also using S2 membership plugin.

    Need help!

    gecko_guy
    Participant

    @gecko_guy

    Same problem, also s2Member, which I can’t disable for security reasons.

    In the meantime please come also to this forum : http://www.s2member.com/forums/topic/s2member-and-loginwithajax-issue/ because this problem comes from s2member too.

    When i disable s2Member plugin, the members, who could not log in, can log in anew.

    In the meantime we are waiting for a solution, if you can answer please Marcus !

    gecko_guy
    Participant

    @gecko_guy

    Just an update. I have also notified s2Member, and should have mentioned in my OP that this has only started happening since the latest update.

    Looking forward to a resolution.

    Many thanks

    Guy

    Thanks Gecko… In the meantime there is something about the demoted time of the member who can not log in… do all you have the same problem, i mean that only some membvers who can not log in or it concerns all of your members ?

    gecko_guy
    Participant

    @gecko_guy

    Anyone who is not an Admin, because the the admin is redirected to the WP admin area, and others are not.

    So something is not working with the re-direction

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘Redirect not working for non admin users’ is closed to new replies.