Support » Plugin: Restrict User Access - Membership Plugin with Force » Redirect not working anymore

  • Resolved luisondehiggs

    (@luisondehiggs)


    Morning!

    One of my customer noticed me few days ago that the suscriber’s user role aren’t redirecting anymore to the page they should to, so I have searched for some misconfiguration and I made many tests… Finally, I couldn’t make it redirect as it used to.

    The other skills of the plugin works fine. I have another plugin to hide the admin bar, but in appearance, it’s not generating conflict at all. There’s no other active plugin that could make conflict, I think.

    It’s important for me and my customer than this plugin works fine. I would appreciate very much if you guys could help me to check this, and if possible, solve it.

    Hope your answer, best regards and thanks,

    Luison de Higgs.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hello

    I have the same issue.
    This plugin STOPPED WORKING!!
    Time in -6month .. now.
    Section restrictions still work. But posts are NOW ALL visible (not only the “public” ones)!!!

    I cannot find a plausible reason. No major updates, plugins added since are testwise deactivated – no change.

    Thanks for your help
    Joerg

    Plugin Author Joachim Jensen

    (@intoxstudio)

    Thank you both for reporting this.

    @luisondehiggs

    Do you mean that pages are no longer restricted, or that they are redirecting to the wrong pages?
    How many access levels do you have?

    @jw2357

    Can you open a new support thread and add a screenshot of the settings for your access level? You can use imgur.com to upload.

    Then I’ll gladly help you from there.

    Hi Joachim. Thanks for your answer. In my case, I mean that people who log in don’t be redirected to the page they used to (private area). They log in and are redirected to WP dashboard.

    For me, restricted pages work fine. Not problem on this. I only have an access level (colegiado) as suscriber. All suscribers were redirected to ‘area-privada’, but now it doesn’t work.

    I hope you can help me! Waiting for your answer 🙂

    Plugin Author Joachim Jensen

    (@intoxstudio)

    Thanks for the details!

    Do you use the [login-form] shortcode to show the login form? Or are you using another plugin to provide the form?

    luisondehiggs

    (@luisondehiggs)

    Hi Joachim!

    No, I’ve always been using ‘Theme My Login’ to use ‘login form’, but if your plugin has its own login form, please let me know how to implement it and I would try to adapt my webpage to this.

    Thanks! This looks like it’s going to be fixed soon =)

    Plugin Author Joachim Jensen

    (@intoxstudio)

    Restrict User Access ought to support any login form as it uses the built-in authentication functionality in WordPress.

    However, if you are using a form from another plugin, it is possible that the redirection set by Restrict User Access is overridden/ignored. Could you double check that Theme My Login doesn’t have a setting somewhere that redirects to the Admin dashboard?

    Hi!!

    Ok I’m gonna check that tomorrow and gonna tell you something about.

    Thanks for your help ! 🙂

    Excuse me,

    How can I use the login form of RUA? I cannot check now but also can’t remember any option to do that. Thanks again!

    Hi!

    I’ve been checking ‘Theme My Login’ and there’s no redirect option if you don’t pay the ‘Redirection extension’. The configuration of this plugin allows me just to change slugs, allow registration and no much more. However, I was trying to find the way to use the form of RUA you told me, but cannot find.

    Please help! =)

    Regards,
    Luisón

    Plugin Author Joachim Jensen

    (@intoxstudio)

    Apologies for the delayed response.

    If the other plugin has no redirection feature unless you pay for it, it is likely that it simply won’t work well with Restrict User Access (i.e. the developers don’t want other plugins to override a feature that they want you to pay for, which is understandable)

    To use the login form in this plugin, simply add this shortcode to any page: [login-form]

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.