Paid Memberships Pro
Redirect Loop with Better WP Security (3 posts)

  1. jamesckemp
    Posted 2 years ago #


    I encountered the redirect loop issue that a few people were having when forcing SSL. I have SSL forced using Better WP Security for my entire site, and when PMP was activated, a redirect loop occurred.

    I did manage to fix this though, by opening up the /includes/https.php in your plugin, and uncommenting the pmpro_besecure_set() function.

    Let me know if you foresee this causing any issues.

    If not, feel free to mark this as resolved. Just wanted to let people know a potential fix.


  2. Slocum Themes
    Posted 2 years ago #

    Hi James,

    I'm glad you were able to get this to work. Here are a couple of alternatives you may want to try, as simply uncommenting this function is not the correct way to approach it. When you update to the latest version of PMPro, your changes will be over-written and you'll have to uncomment the code again.

    1.) Try the "Nuclear" setting to force SSL in the PMPro settings.
    2.) You should be able to add a custom field to your "checkout" page called "besecure" and set that to 1. Here's a resource on custom fields: http://codex.wordpress.org/Custom_Fields#Usage.
    3.) There's a filter you could hook into named pmpro_besecure and return true. Here's a link to the file which contains the filter: https://github.com/strangerstudios/paid-memberships-pro/blob/master/includes/https.php#L66. You'll want to add your functionality to functions.php of your current theme, or create a Child theme. Here's another reference: http://codex.wordpress.org/Plugin_API#Hook_in_your_Filter.

    I hope this info helps.

    Thank You

  3. Slocum Themes
    Posted 2 years ago #

    Hi James,

    Any updates for us on whether or not the above suggestions worked?

    Thank You

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Paid Memberships Pro
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic