Support » Fixing WordPress » Redirect loop upon installing SSL certificate on Bluehost

  • Resolved David Hunter – LAS

    (@david-hunter-las)


    Hello,

    My WordPress installation is hosted with Bluehost. About six hours ago, I ordered an SSL certificate to be installed by Bluehost onto my domain and all its sub-domains. I have never had an SSL certificate before today.

    The Bluehost control panel shows the certificate is installed correctly.

    My website can be accessed via either http://www.huntergeophysics.com or via

    The actual WordPress installation is in blog.huntergeophysics.com, and there is a redirect set up for visitors to http://www.huntergeophysics.com to go to blog.huntergeophysics.com

    So, to give more detail about the folder structure on the server:

    / (root, obviously)
    /public_html
    /public_html/blog/ <– this is where WordPress is installed.

    I also have another WordPress installation at:
    /public_html/astro/
    (accessible via

    Other than whatever Bluehost did to install the SSL certificate, I made no changes before I started having problems.

      My problems

    – When I visit either http://www.huntergeophysics.com or blog.huntergeophysics.com, the plain text content of the main page displays, but all theme elements (e.g. menus, buttons, images) do not display. However, the website is coming through via HTTPS.

    – When I visit blog.huntergeophysics.com/wp-admin/ – I get a “too many redirects” error and nothing loads.

    – When I visit astro.huntergeophysics.com, everything displays perfectly, although it is connected via HTTP and not HTTPS. The admin area for this installation works perfectly.

      What I have tried to do to fix the issues

    1. Altering both the /public_html/ and /blog/ .htaccess file
    as per http://stackoverflow.com/questions/29478863/too-many-redirects-after-switching-wordpress-to-https
    This didn’t do anything.

    2. Deactivating all plugins via FTP as per http://codex.wordpress.org/FAQ_Troubleshooting#How_to_deactivate_all_plugins_when_not_able_to_access_the_administrative_menus.3F
    However, note that step 3 could not be completed because the admin area of the WordPress installation is completely inaccessible.

    3. Talking to Bluehost’s technical support. They told me to fix it myself. #notVeryUseful

    4. Changed “site URL without access to admin area” as per http://www.wpbeginner.com/wp-tutorials/how-to-fix-error-too-many-redirects-issue-in-wordpress/
    This also didn’t help.

      What I need fixed

    1. The theme display on the /blog/ website.
    2. I need to restore access to the admin area on the /blog/ installation.
    3. I need to make the connection to the /astro/ website HTTPS.

    Can anyone please advise how to do this? I’ve got practically no idea what I’m doing here so I would appreciate comprehensive answers.

    Thanks in advance for everyones’ help.
    David

Viewing 4 replies - 16 through 19 (of 19 total)
  • Chad

    (@shortstraw8)

    Hello David,

    Awesome!
    For the astro, it looks to load if I use https so if you haven’t added the force redirects to the wp-config.php or updated the site and home URLs to be https:// instead of http:// then it won’t. You could also add some rewrite to for https in the .htaccess but I suggest against that. Try keeping the .htacces as simple as possible.
    You get the best results updating the urls in wordpress, so in the general settings of the Admin Dasboard update them there to https://astro.huntergeophysics.com/ for the site and home url.

    If you try and do a search replace to update all links in the Database then it will be less likely you would see issues. The force redirect in the wp-config.php however is also a good easy way to get it done.

    Glad that worked out for you and hope that getting it to redirect is as simple.
    Hope this helps

    Yup, simply changing the URLs in WP’s Settings > General solved that issue entirely, from what I can gather. Perfect!

    Thanks very much for your advice. I appreciate your’s and wphostonline’s time. 🙂

    (Marking this topic as resolved; many thanks again!)

    Thank you!

Viewing 4 replies - 16 through 19 (of 19 total)
  • The topic ‘Redirect loop upon installing SSL certificate on Bluehost’ is closed to new replies.