Support » Fixing WordPress » Redirect Loop problem

  • When I try to access my site I get a Redirect Loop error page on Firefox (IE justs sits there, looped).

    Here’s what I have done:

    1. Setup my blog on its own directory
      • Setup options to have my blog on my root dir (I copied and changed index.php, had no .htaccess). Until this point everything works as expected.
      • In Reading Options I selected a static page as my front page.

    After selecting a static page I go to the main page and it works, go to other pages and they work. What is not working is the blog section (in my case is under the directory /noticias)

    My goal is to have a static front page, a gallery, a blog and a contact form. Everything works but the blog URL. That’s where I get the redirect loop.

    What is wrong?


Viewing 7 replies - 1 through 7 (of 7 total)
  • Hey man, I had the exact same problem. If you can access your database, browse the table ‘wp_options’ and find the row ‘home’. The value for it should be your url for your blog. For whatever reason (I’ve got no idea why this matters, but it does), remove the ‘www’ from the value, and load your blog again after saving your database. That’s all it took for me, hope it works for you.


    Did that, it didn’t worked. Now it’s configured that way and it doesn’t make a difference.

    In fact, changing that value directly in the database or via the Options menu is the same.

    Thanks anyway,

    After experimenting for a while I came to the conclusion that permalinks + wordpress on its own directory + a static front page don’t get along too well.

    So, for the time being, I’m solving this with a template index.php with static content (Loop only on sidebar for a calendar with future events). And the blog comes under its own category (for /noticias).

    Hope this will help others or, more properly, ring a bell on someone with the same problem and find a solution.


    Here is what i had…

    I had a static ‘front page’ (set with a page template) and a ‘posts page’… I had a link from the ‘front page’ to the ‘posts page’. But, when I clicked to go to the ‘posts page’ my browser kept saying it was stuck in a Redirect Loop. Also, for development reasons I had all the posts set for ‘unpublished’.

    Here is what i found…

    Turns out wordpress doesn’t know what to do when your ‘posts page’ doesn’t have any posts in it, or all your posts are set to ‘unpublished’. I thought the ‘endwhile; else:’ statement would pick up the slack, but it didn’t.

    Hope this helps… Even if your situation is different, consider the possibility that the browser is looking for something that doesn’t exist.

    btw, after figuring this out i feel like retard… 😉

    try going into your settings and changing the blog url to the directory that wordpress is installed, and not the direct link to the blog itself.

    worked for me.



    I had a similar problem and after trying everything, I found there was a redirect line of code that was floating around in the .htaccess file. I got rid of it, and that solved the issue.




    Just hit save again….that fixed it for me…

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Redirect Loop problem’ is closed to new replies.