Support » Networking WordPress » Redirect loop on subdirectory sites

  • I installed WP 3.0.4 on our server last week. I followed all of the setup directions for multisite, and it seemed to work fine. The only problem is that when I link to one of my child sites (,, etc) without using a trailing slash, it shows a redirect loop error. With a trailing slash, it’s fine.

    I tried adding code to the .htaccess to add a trailing slash to all URLs, but it made no difference.

    I’d appreciate any advice on this. Thank you.

Viewing 11 replies - 1 through 11 (of 11 total)
  • What’s in your .htaccess file?

    Default multisite code for subdirectories is now in my htaccess:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    That looks good. What plugins?

    No plugins currently. This is a completely fresh WP 3 install. Really strange issue.

    Yeah that is odd. I wonder if it’s a weird httpd.conf setup. Are multi views on?

    This is the vhosts record for the install (with vital info blacked out)

    <VirtualHost —.—.—.144:80>
    DocumentRoot /var/www/
    ErrorLog /var/log/apache2/
    TransferLog /var/log/apache2/

    I hope this makes sense – We have a WPMU install on the same server using the same domain. Could that interfere and cause this problem (or need a special vhosts setting) even though the subdomain is different?
    The WPMU is called later in the vhosts file and uses the subdomains *, so it shouldn’t interfere, but at this point, I’m willing to look at anything.

    I’m a bit of a novice on httpd.conf, so if there are other settings that I should try, please let me know.

    Thanks for your effort so far.

    Its not in the virtual hosts. It’s part of the AllowOverride section.

    It looks like Multiviews is enabled under Options. Should it be?

    Yes. What are the options set to?

    I have exactly same problem with WordPress 3.3.1. Any suggestions?

    Same answer. Probably your httpd.conf file.

    And Mikko Virenius, after 11 months of no reply, it’s okay to make your own topic 🙂 In fact, we’d rather you did.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Redirect loop on subdirectory sites’ is closed to new replies.