WordPress.org

Support

Support » Multisite » Redirect Loop on Blog Home Page

Redirect Loop on Blog Home Page

  • When I visit my blog homepages http://magoosh.com/gre or http://magoosh.com/gmat I get a redirect loop. But if I refresh the page, the error goes away and I can get to the homepage. This is happening with both Firefox and Chrome browsers.

    I don’t seem to have an issue if I go directly to a post. I’ve tried removing various plugins to find the culprit but have had no luck. In addition, I recall seeing this issue from the moment I set up WP3.0 multi-site.

    I’d love some help. Thanks!

Viewing 15 replies - 1 through 15 (of 25 total)
  • Are you using any caching plugins on your WP install or your server?

    Andrea Rennick

    @andrea_r

    Customer Care at Copyblogger Media and Studiopress

    Did you check with your host to see if they let you run multisite?

    @ipstenu I was using WP Super Cache, but I deactivated and deleted it and am still seeing the issue.

    @andrea_r I use Amazon Web Services. The sites seem to be running fine except for when I hit the homepage – in which case I need to refresh

    Amazon Web Services … Don’t they do a lot of siloing and caching on THEIR end?

    I’m not sure, but I can look into it. Do you know why caching would cause a redirect loop? I’m also confused as to why this only happens the first time I hit the site, but when I refresh the issue goes away.

    The refresh is the key. Something cached the bad login info. Since it happens to everyone, it’s probably the server and not your PC.

    I now have more information. I think the issue may be because I have a multisite install on WP 3.1 with the files in a wordpress directory within the root rather than directly in the root directory. I’ve tried a few things to move the install up a level to the root to no avail. Any ideas?

    I think the issue may be because I have a multisite install on WP 3.1 with the files in a wordpress directory within the root rather than directly in the root directory.

    Are you trying to access WordPress as if it WAS in root, but with a non-URL location? That is you go to domain.com but the code is all in domain.com/wordpress ? Cause… yeeeeeah, that’d be weird.

    You CAN move it, but it’s tricky. See http://codex.wordpress.org/Moving_WordPress#Moving_WordPress_Multisite

    Yes, I go to domain.com to access my wordpress install but all the code is in domain.com/wordpress. I know you can do this with a single install http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory, but I guess I shouldn’t have done this with multisite. I installed multisite back in August. As far as I can remember I’ve always had this redirect problem, but since I could get around it by refreshing a few times I foolishly thought it would go away at some point.

    When I go to domain.com to access the main site, I have no problems with redirects. I access my other sites at: domain.com/site1 and domain.com/site, and that’s when I get the “too many redirects” error.

    Last night I copied everything from the domain.com/wordpress directory to the domain.com/directory. Also, both .htaccess and wp-config seemed to be configured properly for access at domain.com. I also changed the DocumentRoot to use the domain.com directory. I checked the database and while there are references to the domain.com/wordpress path, most were for images and comments (so those broke), but nothing related to the actual path.

    And even with this, I would still get the redirect error. I’m pretty stuck at this point…

    I guess I shouldn’t have done this with multisite.

    Yep 🙂 Don’t do it, doesn’t work, causes problems.

    Looking at your list of what you did, you did NOT make all the changes needed.

    Look at wp_blogs and (I think) wp_sites.

    You ACTUALLY need to search for the foldername on it’s own, NOT domain.com/foldername

    I actually manually checked wp_blogs and wp_site, and didn’t find any reference to the foldername. I just checked again.

    wp_site looks like this (there’s only 1 row)
    domain: domain.com
    path: /

    wp_blogs looks like this (4 rows)
    domain: domain.com (for all 4)
    path: / ; /site1/ ; /site2/ ; /site3/

    Well. That’s weird. Though….

    http://magoosh.com/gre gets a loop. http://gre.magoosh.com/ works fine.

    Well gre.magoosh.com is not on the wordpress install. That’s our application and is complete custom, in fact it’s on a different server.

    The wordpress install is for the respective blogs of each application. The site structure is:
    magoosh.com
    magoosh.com/gre
    magoosh.com/gmat

    Where is http://gre.magoosh.com/ pointing to?

    On MY server, subdomains are located in /public_html/subdomainname (and yes, you can get to subdomains at domain.com/subdomain for most servers… unless you redirect them around).

    In your case this would be /public_html/gre … and that would kinda conflict with magoosh.com/gre you see. Apache thinks they’re BOTH the same thing.

    gre.magoosh.com has an ANAME record to a completely different ip address (different server)

    The other issue is that I get the redirect error on other pages like magoosh.com/home (thats a page under the magoosh.com site not a separate site like magoosh.com/gre) and there is no subdomain at home.magoosh.com

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Redirect Loop on Blog Home Page’ is closed to new replies.
Skip to toolbar