WordPress.org

Forums

WordPress HTTPS (SSL)
[resolved] [closed] Redirect loop error with WooCommerce (10 posts)

  1. MDesigner0
    Member
    Posted 1 year ago #

    I found a standard page in WooCommerce where a redirect loop error occurs.

    http://sitename/my-account/lost-password

    Attempting to visit this URL results in a redirect loop if the HTTPS plugin is activated.

    http://wordpress.org/extend/plugins/wordpress-https/

  2. fox-didl
    Member
    Posted 1 year ago #

    Sure, I have the same problem. Is there a fix for this until now?

  3. fox-didl
    Member
    Posted 1 year ago #

    After deactivating wordpress https the loop of woocommere is gone. This is not nice. Is there a fix for this? I hope...

  4. fox-didl
    Member
    Posted 1 year ago #

    With help from WooCommerce I've found a goal.

    Make an update like this in Woocommerce settings:
    http://cld.wthms.co/a6gq

    And for wordpress https activate this:
    Activate only Force always admin with https. Same as Force-SSL-Admin. On my site http://shop.pronatur24.eu it's working now.

  5. Chirag Vora
    Member
    Posted 1 year ago #

    Thanks to Google webmaster tools, I observed this redirect loop on my site.

    @fox-didl your method didn't solve the problem with my site. But it certainly showed me the way. :)
    I kept HTTPS settings same as yours.

    But I also has to do this:on HTTS plugin settings page, within URL filter added this into Secure Filters textbox:
    /my-account

    and Saved changes

    That worked for me.

  6. fox-didl
    Member
    Posted 1 year ago #

    Hi Chirag. Thanks this is correct. I've solved this problem a few months ago.

  7. Chirag Vora
    Member
    Posted 1 year ago #

    @MDesigner0 you can mark this as resolved.

  8. MDesigner0
    Member
    Posted 1 year ago #

    Thanks!

  9. marie911
    Member
    Posted 1 year ago #

    Hi there!
    Anyone can help me.. I'm having the same problem. In Woocommerce my login and logout are making loop redirection on "my-account" page..
    And really don't know what to do anymore.
    Also, I'm not using the HTTPS plugin :(

  10. esmi
    Forum Moderator
    Posted 1 year ago #

    If you require assistance then, as per the Forum Welcome, please post your own topic instead of tagging onto someone else's topic.

    This 11 month old resolved topic is now closed.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress HTTPS (SSL)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic