Support » Fixing WordPress » redirect loop after update WordPress 4.4.1

  • Resolved Adrian K.

    (@adriankimmitt)


    Website was running 4.4 then updated to 4.4.1 and started having the redirect loop on the front of the website. Sub-pages of of the website work, and access to the wp-admin panel works fine. The problem is only a re-direct loop from the main page.

    – disabled ALL plugins = problem still persists
    – changed wordpress/site url from WWW to not having www = problem still persists
    – deleted .htaccess file completely = problem still persists
    – deleted all (meta_key = ‘_wp_old_slug’) from the wp_postmeta table = problem still persists
    – installed new theme (twentysixteen) = problem still persists

Viewing 15 replies - 1 through 15 (of 39 total)
  • done all of you above also

    I am having this problem on multiple wp 4 4 1 sites that updated overnight.

    wp-admin causes redirect loop with a 403 forbidden.

    any help would be appreciated

    Moderator Matthew

    (@kidsguide)

    Volunteer Moderator

    I would recommend that you check out this thread. Lots of talk is going on over there about how to resolve this.

    Adrian K.

    (@adriankimmitt)

    *update*
    Been doing tons of trial and error, and so far it seems like the problem might be the CUSTOMIZE > STAIC FRONT PAGE. By choosing any static front page, I am stuck in re-direct loop, but changing to BLOG POSTS fixes the error. So it seems to be how its re-directing and loading static front pages.

    Adrian K.

    (@adriankimmitt)

    @matthew: NO! That link does NOT have any useful information, nor a solution, and they have NOT tried some of their items I have listed above. My posting here is more detailed, clearer, and has additional trial/error data that the other post does not. Please do not refer people to that post, as its useless. -1 points for you.

    Mine also auto updated and am having the same problem – and I’ve tried all the same crap from that “thread” – and I too have found that removing a static front page and setting it to “Front page displays: Your latest posts” gets it back working but not the way I had it. I’m looking for an actual answer and hoping someone will find it soon!

    Adrian K.

    (@adriankimmitt)

    [ TEMP FIX ] *NOT A PERMANENT SOLUTION*

    It seems to be be a problem with PERMALINKS and STATIC PAGE.

    – Permalinks –
    Plain: this works and loads fine
    Day + Name: problem still persists
    Month + Name: problem still persists
    Numeric: problem still persists
    Post Name: problem still persists
    Custom: problem still persists

    So you could set permalinks to be PLAIN, and this will get your site working in the mean time, however your site is going to get re-indexed with new URL’s and this is not a valid solution. Just a informative fix along the path to a real solution…

    So it seems to be a problem specifically with REDIRECTS…. I am still researching and will update with further info.

    Adrian K.

    (@adriankimmitt)

    * RESEARCH IDEA*
    This problem MIGHT come from a conflict with PHP versions and not being fully supported. WordPress 4.4.1 recommends 5.6 or greater, however they have no specific version required version for 4.4.1

    >> My server is running 5.5.22 and I have the re-direct loop error.

    still researching…..

    Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    The problem is only a re-direct loop from the main page.

    @adriankimmitt I may have missed it but can you post a link to your site?

    Thanks Adrian K for the above information – I am a very new member using WordPress and the permalink change did fix the problem for my localhost installation. I will be watching closely for further posts.

    ou have to contact your hosting company and get them to fix it on their end.

    This is from 2 hours ago on WordPress support:
    “cPanel users may find wp-admin blocked due to an update to their server’s mod_security rules. Preliminary reports suggest rules #214620 and #214940 are to blame. Please contact your hosting provider if you encounter this.”

    I just spent an hour online with my hosting provider, and they created a workaround so I could get into my site.

    This error is happening to all of our sites that have been updated to 4.4.1. After logging in we get the re-direct loop error. Our workaround has been to add ‘/index.php’ to the end of the web address. So http://domainname.com/wp-admin/ becomes http://domainname.com/wp-admin/index.php.

    All public web pages are fine. We just get that error after logging in.

    Unsure what the heck is wrong and how to fix?

    Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    Guys? Per the forum welcome please post your own topic.

    How-To and Troubleshooting

    What Adrian K. is describing is not the problem you are having. Please raise your own topics. It’s the best way to get your problem the attention it deserves.

    I’m having the same problem as @adrian K. with one of my WP sites. Thanks for the troubleshooting info so far, I tried all of your tests with the same results.

    I can confirm that for me, changing the Permalink setting to Plain also fixes the Redirect Loop (not ideal, but at least it’s a temporary fix).

    The site was using PHP 5.4. I upgraded to 5.6 and it did not fix the redirect loop issue for me.

    I’ll research some more, too.

    Hello all –

    Jan — I found the posts above ALL relevant to what we are testing.

    We too saw the error and ran through the same testing that Adrian K. (thanks for reporting a couple of times on progress, Adrian) describes at top of thread. We manage and support about 25 different WordPress sites — about 10 on Genesis, 14 on Elegant Themes, and 1 on Thematic.

    All of those themes are are working out fine — except for just one on Genesis that exhibits the same problem — and resolution (when Permalinks are changed to “plain”).

    For other sites checked:

    • custom permalinks (usually /%category%/%postname% )
    • Under SETTINGS:READING — we have checked and two other sites are fine with a static homepage set
    • Check PHP version at host: 5.4. Changing now to 5.6.
    • ModSecurity status: not active (we usually turn this off and them use WordFence)

    Will report.

    Same problem.

    Changed permalinks to “plain” and the site is working again. Thanks for the help everyone.

    I’m glad it’s back up, but this is very annoying because the site is brand new and probably still getting index by google.

Viewing 15 replies - 1 through 15 (of 39 total)
  • The topic ‘redirect loop after update WordPress 4.4.1’ is closed to new replies.