Support » Plugin: WordPress HTTPS (SSL) » Redirect loop

  • Hi,

    I have installed the plugin, configured it with ‘Always use HTTPS while in the admin panel’ and ‘Force SSL Exclusively’ checked.

    On the page that presents a contact form, in the plugin’s metabox, I checked the ‘Secure Post’ button to force ssl on just this page (I did the same for another form on the site)

    Now when I navigate to Contact, the page won’t load and I get the following error:
    ‘This webpage has a redirect loop
    ERR_TOO_MANY_REDIRECTS’

    I tried resetting the plugin, following the directions included in the readme file.

    Is there anything that gets added to the wp db that I should be aware of? Are there settings in either .htaccess or wp-config.php I should be aware of? I am using a theme developed on top of Underscores which is a pretty barebones theme — I wouldn’t know if they have something that forces http on pages (I read somewhere that was causing this problem for someone else)

    I appreciate how much time and effort you’ve invested in this and whatever guidance you can provide me with to resolve this issue.

    https://wordpress.org/plugins/wordpress-https/

Viewing 1 replies (of 1 total)
  • I am having the same issue.

    We recently added an SSL certificate to enable checkout on our woocommerce store and are trying to have only the store pages directed to HTTPS. Unfortunately the social stats we have on our blog posts are connected to the original HTTP urls and are now all reset to 0 because of the HTTPS new url. This is why we’d only like the store URLS to be secure, as to retain the old links.

    It seems as though technically it is redirecting HTTPS pages back to HTTP, but the URLs are also still automatically directing back to HTTPS and since it’s forced HTTP, it claims the secure version does not exist.

    This plug seems very convenient, but not sure how to fix the redirect loop issue.

    Thanks in advance for any assistance.

Viewing 1 replies (of 1 total)
  • The topic ‘Redirect loop’ is closed to new replies.