Support » Plugin: Razorpay for WooCommerce » Redirect Link after Successful payment is not correct

  • When a user pays using the razorpay plugin on my woocommerce website they are not redirected to the current link on payment completion for some of the payment methods.

    These payment methods are:
    1. Credit/Debit Card
    2. Netbanking

    They are redirected to this link:
    https://example.com/checkout/order-received/?key

    As you see this page doesn’t have the required key value pair which fails the payment and the order doesn’t go through. Although the payment has been successful as seen in the razorpay dashboard.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author chetangn

    (@chetangn)

    Hi @bhanusinghkre

    Can you please provide us some more information about this issue.

    • Which version of the Razorpay plugin you are using?
    • Which version of the Woocommerce plugin you are using?
    • Is this issue happening for only these 2 payment methods?
    Thread Starter bhanusinghkre

    (@bhanusinghkre)

    Hey @chetangn,

    Please find my response.

    Which version of the Razorpay plugin you are using? – 2.4.2
    Which version of the Woocommerce plugin you are using? – 4.1.1
    Is this issue happening for only these 2 payment methods? – Yes.

    Also While we are at it, I would like that we can for every payment mode available to us to be sure.

    • This reply was modified 8 months, 3 weeks ago by bhanusinghkre.
    Plugin Author chetangn

    (@chetangn)

    @bhanusinghkre thank you for providing the information.

    We tried to reproduce this issue with the above-mentioned versions but not able to reproduce it, it’s working for us with these versions. Suggesting you update our razorpay woocommerce plugin to the latest version (2.5.0), as we had fixed some redirection issues in the previous releases.
    If you are still facing the same issue after updating to the latest version then, Could you share your account ID and other details on our support page? We’ll need to look a little deeper into your account config to understand the problem.

    • This reply was modified 8 months, 3 weeks ago by chetangn.
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Redirect Link after Successful payment is not correct’ is closed to new replies.