WordPress.org

Support

Support » Multisite » redirect issue after ugrade php / sql 4 to php / sql 5 multisites only

redirect issue after ugrade php / sql 4 to php / sql 5 multisites only

  • I went the through the php / sql upgrade this weekend (v 4 to v 5), and all seems okay with my standard worpdress installs, but the multi site installs on this server have some kind of infinite redirect issue now and fail to load any pages. Anyone else have this issue?

    Steve

Viewing 15 replies - 1 through 15 (of 19 total)
  • By upgrade you mean you copied the database to the new, SQL 5, install?

    Well, I am having this same issue on two different web sites on two different servers. I upgraded the sql / php and it failed with the multisite sites – the one with the first fail:
    I took the backup I had made (while the database was on php / sql 4 version) – and then imported the sql file and imported it to a new database with the phpmyadmin 5 and that did not work, changed the credentials in wp-congif and it still did the infinite redirect fail – then I took the php 4 version and imported straight into the database that had been converted to php/ sql 5 overwriting the main one, and it still has the redirect fail.

    It fails / redirect loops on the home page, as well as mysite.com/wp-admin/ – strange thing is that going to wp-admin/upgrade.php brings up a page, but clicking upgrade basically refreshes the screen and it dies.

    You can’t upgrade SQL 4 to 5, which was the point of my question (that’s an annoying SQL thing).

    On your new PHP 5/SQL 5 box, can you make a NEW install of WP and turn on MultiSite? Let’s try and see if you have a bad install of the 5s or something else 🙂

    Also, what ELSE is different? Are these new servers or old ones?

    Yes, I made a new wp 3.2 multisite and it seems to work fine.

    Same server, nothing else has changed, just the upgrade to sql 5.

    I paid extra to get supreme support from my host and asked them to double check everything, including all the php / sql modules being upgraded and installed properly. We went through the process of importing the sql 4 database into a new blank database (which is not running v5) – and still have the same redirecting loop issue.

    I tried check / repair of this database and still fails.

    This site was a wpmu v 1.5 (I think) that has been upgraded several times over the years.

    I tried renaming the plugins folder to make sure it was not a plugins issue (although I really think this install was not running any plugins)

    I just had the same issue occur on a different server, with a different host and the mu sites on that server did the same thing. They were able to re-import the backup dumps into php/sql5 and everything runs fines on that server, taking away this redirecting issue – but that does not seem to work properly on this one server with my other host.

    the dot com redirect loops, the dotcom/wp-admin redirect loops.. going to wp-admin/upgrade.php shows a page, click the buttin, it changes the page and says done – and does not seem to change anything – very strange.

    The redirect look is often caused by a miss-match between http://www.domain.com and http://domain.com

    Check in your DB and your wp-config.php to make sure it’s the same all around.

    Thank you so much for helping with this!

    I am assuming that in wp-config I look to this line for this info:
    define(‘DOMAIN_CURRENT_SITE’, ‘mysite.com’ );

    But where would I look in the database for this info?
    Also, what are the best ways to look into the database? Should I use phpmyadmin or try to open it in a text editor like from open office or editplus or is there something better?

    Andrea Rennick

    @andrea_r

    Customer Care at Copyblogger Media and Studiopress

    go into phpmyadmin and use the search tab.

    Did the search, and in wp-site meta it shows the same type of setup; http://mysite.com

    This is so weird. Would it be possible for someone to import my database into a fresh install on a different server and see if it’s working right there, and then re-export the database from sql v5 or would that not work either?

    Check the PREFIX of that table in wp_site though. It’s in a separate field in the table.

    in the wp_site section, I just see three fields – “Id” is 1, “domain” is mysite.com, “path” is /

    I do not see a field for prefix in wp_site

    Could that be the problem?!

    Er… not prefix, sorry, Brain fart. Don’t know where I got that.

    Okay.

    Do a search for http://www.mysite.com in the WHOLE database.

    okay, I see two instances of the http://www.mysite in the database, on is in wp_signups and the other is in wp_users – should I edit those two blocks and take out the www? Would that be causing the redirect on home page issuse?

    Edit the ones in wp_users, it MIGHT be causing it.

    okay, tried that – still not working.. I think that signup was someone trying to exploit something from a registration in 2004 – they had signed up with wwww.mysite.com (4 W’s) as username and site name –

    I wonder if my database had some corrupt tables while in php / mysql V4 – and then when it got upgraded / imported to V5 is truncated some stuff that was needed or something..

    It’s … possible.

    How many sites aand users are on your network?

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘redirect issue after ugrade php / sql 4 to php / sql 5 multisites only’ is closed to new replies.
Skip to toolbar