Support » Plugin: WP RSS Aggregator - Automatic and Powerful Content Aggregation and Curation » Redirect /feed-items/newstory to another page

  • Resolved websitehelperuk

    (@websitehelperuk)


    Hi,

    I am noticing a fair bit of 404 because feed items are being indexed by Search Engines. My feed items are only kept for max 2 days and don’t really want them being indexed, anything older than 2 days gets dumped. Is there a way to add a noindex to feed items.

    At the moment I have just added a redirect:
    RewriteRule ^(.*)feed-items(.*)$ http://www.example.com/all-feeds-here [L,R=301]

    Just don’t want people landing on pages with a headline and a short excerpt as it looks very spammy.

    https://wordpress.org/plugins/wp-rss-aggregator/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi websitehelperuk,

    Have you tried to enable the Set links as nofollow by checking this option like shown here: http://take.ms/5Uhvq ?

    You can read more about the other option here.

    Hope this helps.

    Thread Starter websitehelperuk

    (@websitehelperuk)

    That just adds a nofollow rule to feed items (outbound links on main feed page http://bit.ly/2aVPdq2). It is the actual feed item post pages that the plugin generates that are a concern. If they have been removed it just causes a 404 error.

    Like I said at the moment we are just redirecting all item posts back to the feed page using RewriteRule ^(.*)feed-items(.*)$ http://www.example.com/all-feeds-here [L,R=301]

    Hi websitehelperuk,

    If I understood everything correctly, then the suggestion of my colleague Eric should prevent search engines from following, and therefore indexing, pages of individual Feed Item posts. If the search engines cannot index them, then these items will not appear in search results, and this would prevent visitors from landing on the new items that get imported after you apply the suggested option. For the feed items that are already indexed before you apply the “Set links as nofollow” option, your server rewrite rule should do the job of hiding the feed item pages from the visitors.

    Does this solve your problem?

    We’re experiencing the same problem.

    For exemple, mysite.ca is showing a specific RSS feed from externalsite.com.

    The plugin is configured with the following:
    Link title = checked
    Set links as nofollow = checked

    So basically, we have a list of results in a Widget from an RSS feed on our mysite.ca and the links are pointed towards externalsite.com with the nofollow attributes.

    BUT! (that the situation the OP is talking about and that we’re experiencing too), the plugin is still generating a custom post type detail page…

    In our case, it’s coming up like this:
    http://www.mysite.ca/feed-items/name-of-the-feed-showed-in-a-slug/
    and this page is being crawled and referenced by Google.

    That is why the OP is creating a 301 redirect with the regex config but that is just a temporary workaround, not a permanent solution.

    Is it possible to “noindex” the detail page (sometimes called the single page) directly from the plugin instead of having to revert to code?

    If you don’t mind me adding, it’s the same situation as found in this topic -> https://wordpress.org/support/topic/wp-rss-aggregator-creates-unwanted-posts-from-feed-items/

    Hi @guimos,

    Sorry for missing your reply here. We failed to notice some replies on old threads since the new look of WordPress.org Forums takes place.

    With regards to your issue, currently, the plugin does not have any settings which can add the “noindex” flag on single Feed Item page. We’re afraid you’ll have to do it by adding some custom code.

    Sorry for this inconvenience.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Redirect /feed-items/newstory to another page’ is closed to new replies.