Support » Networking WordPress » Redirect All non-WWW to WWW on WordPress Multisite

  • Hi!
    I just ask how to redirect all link from non-www to www on WP multisite?. Everytime i type ‘example.com/subs-site’ or ‘example.com/category/the-post’, it will redirect to main site ‘example.com’. So, how to fix this? thank you. and i’m sorry if this question already exist. It’s hard to find it. Thank you. 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • Did you ever figure this out?

    If I type in http://mydomain.com/path

    It redirects to http://www.mydomain.com

    It leaves the path off. I want everything to have the www.

    Did you ever figure this out?

    If I type in http://mydomain.com/path

    It redirects to http://www.mydomain.com

    It leaves the path off. I want everything to have the www.

    Fortunately, yes, but your site must registered on Cloudflare. I think there’s must be a configuration on .htaccess somehow but so far nothing. Here’s my alternative configuration if you want to follow me.
    1. Make sure you have setting up your site on Cloudflare (verification, domain linking, etc).
    2. If you have done all above, go to “Page Rules” > “Create Page Rules”
    3. Fill your non-www site on “If the URL matches” field and add asterisk (*) character after your url (ex: http://example.com/*)
    4. On “Then the settings are” section, set to “Forwarding URL” > “301 – Permanent Redirect” > then type your url with www and add $1 after your url (ex:http://www.example.com/$1).
    5. Hit “Save and Deploy” and activate the page rule.
    6. Clean your DNS cache and browser cache (it’s additional) and test in incognito mode, if it work, congratulation. If not, maybe need time about 5 minute or less.

    That’s all i know. May help you with your problem. ^^

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Redirect All non-WWW to WWW on WordPress Multisite’ is closed to new replies.