Support » Plugin: Yoast SEO » Recurring Single Post 404 errors

  • Resolved B1gJ4k3

    (@b1gj4k3)


    I recently installed Yoast on my networks installation and network activated it. Since then, I’ve been experiencing recurring 404 errors on my single blog post pages on my main site. I thought it was just a permalink thing, and a few times, I just refreshed the permalinks and things went back to normal.

    Today, when it happened, without refreshing permalinks, I started deactivating plugins to see if I could relate one to the other. As soon as I deactivated Yoast, my single post started working again without doing anything else.

    Has anyone ever experienced this before? I have a hard time believing it is directly related to Yoast, but it’s the only conclusion I can come to. I’m guess it probably has something to do with my htaccess file, so I’ll post that here too:

    # Use PHPBETA Single php.ini as default
    AddHandler application/x-httpd-phpbetas .php
    #WFCACHECODE - Do not remove this line. Disable Web Caching in Wordfence to remove this data.
    <IfModule mod_deflate.c>
    	AddOutputFilterByType DEFLATE text/css text/x-component application/x-javascript application/javascript text/javascript text/x-js text/html text/richtext image/svg+xml text/plain text/xsd text/xsl text/xml image/x-icon application/json
    	<IfModule mod_headers.c>
    		Header append Vary User-Agent env=!dont-vary
    	</IfModule>
    	<IfModule mod_mime.c>
    		AddOutputFilter DEFLATE js css htm html xml
    	</IfModule>
    </IfModule>
    <IfModule mod_mime.c>
    	AddType text/html .html_gzip
    	AddEncoding gzip .html_gzip
    	AddType text/xml .xml_gzip
    	AddEncoding gzip .xml_gzip
    </IfModule>
    <IfModule mod_setenvif.c>
    	SetEnvIfNoCase Request_URI \.html_gzip$ no-gzip
    	SetEnvIfNoCase Request_URI \.xml_gzip$ no-gzip
    </IfModule>
    <IfModule mod_headers.c>
    	Header set Vary "Accept-Encoding, Cookie"
    </IfModule>
    <IfModule mod_rewrite.c>
    	#Prevents garbled chars in cached files if there is no default charset.
    	AddDefaultCharset utf-8
    
    	#Cache rules:
    	RewriteEngine On
    	RewriteBase /
    	RewriteCond %{HTTPS} on
    	RewriteRule .* - [E=WRDFNC_HTTPS:_https]
    	RewriteCond %{HTTP:Accept-Encoding} gzip
    	RewriteRule .* - [E=WRDFNC_ENC:_gzip]
    	RewriteCond %{REQUEST_METHOD} !=POST
    	RewriteCond %{HTTPS} off
    	RewriteCond %{QUERY_STRING} ^(?:\d+=\d+)?$
    	RewriteCond %{REQUEST_URI} (?:\/|\.html)$ [NC]
    	
    	RewriteCond %{HTTP_COOKIE} !(comment_author|wp\-postpass|wf_logout|wordpress_logged_in|wptouch_switch_toggle|wpmp_switcher) [NC]
    	
    	RewriteCond %{REQUEST_URI} \/*([^\/]*)\/*([^\/]*)\/*([^\/]*)\/*([^\/]*)\/*([^\/]*)(.*)$
    	RewriteCond "%{DOCUMENT_ROOT}/wp-content/wfcache/%{HTTP_HOST}_%1/%2~%3~%4~%5~%6_wfcache%{ENV:WRDFNC_HTTPS}.html%{ENV:WRDFNC_ENC}" -f
    	RewriteRule \/*([^\/]*)\/*([^\/]*)\/*([^\/]*)\/*([^\/]*)\/*([^\/]*)(.*)$ "/wp-content/wfcache/%{HTTP_HOST}_$1/$2~$3~$4~$5~$6_wfcache%{ENV:WRDFNC_HTTPS}.html%{ENV:WRDFNC_ENC}" [L]
    </IfModule>
    #Do not remove this line. Disable Web caching in Wordfence to remove this data - WFCACHECODE
    # Changed PHP handler from application/x-httpd-php54s to application/x-httpd-phpbetas on Fri Dec 18 09:10:10 MST 2015.
    
    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress
    
    # BEGIN MainWP
    
    # END MainWP
    

    Anybody know what might be going on here?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Did you get anywhere with this? I’ve not got Yoast installed on this specific site, but had the same problem. I worked out that it was because the first word of the blog was the same as another page on the site with that word as permalink.

    As I didn’t want to change the permalink of the page, I just changed the address of the post itself, not the title. And it worked.

    May not be the same issue for you though.

    No, unfortunately, I never found a solution. The client wasn’t using Yoast much anyway, so I just ended up deactivating it and haven’t had the problem since.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Recurring Single Post 404 errors’ is closed to new replies.